Bug Hunting Session
Bug 114026 - LibreOffice Vanilla does not recognize existing JDK installation
Summary: LibreOffice Vanilla does not recognize existing JDK installation
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 115354 (view as bug list)
Depends on:
Blocks: MacOS-Vanilla
  Show dependency treegraph
 
Reported: 2017-11-24 15:45 UTC by Alex Thurgood
Modified: 2018-02-01 08:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2017-11-24 15:45:53 UTC
Description:
Donwloaded the latest version of LibreOffice Vanilla from the Apple Store

1) Started LO Vanilla
2) Entered Preferences - Advanced
3) No Java is recognized, the dialog is non-functional (greyed out)
4) This has consequences such as the inability to open embedded hsqldb database files or any database that requires a JDBC driver, and also renders extensions that require Java useless.

Steps to Reproduce:
See above

Actual Results:  
No JDK recognized

Expected Results:
JDK should be recognized


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Alex Thurgood 2017-11-24 15:58:08 UTC
@Tor : seems like you get lumbered with the baby ?
Comment 2 Alex Thurgood 2017-11-24 15:59:04 UTC
If the intention is not to included Java support, then this must be made clear on the AppStore page, as well as the consquences thereof (see original comment).
Comment 4 Adolfo Jayme 2017-11-27 00:19:16 UTC
Apple’s App Store explicitly forbids software using runtimes like Java. That is why it’s disabled in the Vanilla builds.

http://appleinsider.com/articles/10/10/20/apple_issues_review_guidelines_for_mac_app_store.html
Comment 5 Alex Thurgood 2017-11-27 10:57:31 UTC
(In reply to Adolfo Jayme from comment #4)
> Apple’s App Store explicitly forbids software using runtimes like Java. That
> is why it’s disabled in the Vanilla builds.
> 
> http://appleinsider.com/articles/10/10/20/
> apple_issues_review_guidelines_for_mac_app_store.html



The point is that it doesn't mention any of this on the AppStore page itself.


What good is referring to a LibreOffice page for which a link isn't even available on the AppStore page ? If this is how Vanilla bug reports are going to be handled, then frankly it isn't even worth the time for me to invest in reporting them.

I would add that the AppStore accepts paying apps such as SweetHome 3D which includes a full Oracle JDK (http://www.sweethome3d.com/fr/download.jsp), so clearly the link referred to has either got its sources wrong or is out of date.
Comment 6 Tor Lillqvist 2017-11-27 11:06:22 UTC
Including a JDK (or JRE) would be an option, sure. If just somebody had the resources to do the work.

We will try to improve the App Store descriptive text when the next build is uploaded.
Comment 7 Alex Thurgood 2018-02-01 08:12:35 UTC
*** Bug 115354 has been marked as a duplicate of this bug. ***