Bug 114046 - EDITING by PASTING text in the formula bar should not transfer the source format
Summary: EDITING by PASTING text in the formula bar should not transfer the source format
Status: RESOLVED DUPLICATE of bug 117017
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All macOS (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-25 17:04 UTC by gurol
Modified: 2018-09-02 18:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gurol 2017-11-25 17:04:26 UTC
Description:
Pasting directly into the formula bar should have text-only (not formatting is transferred into the cell)

Steps to Reproduce:
1.Copy a formatted text (e.g. a text with Times New Roman)
2.Switch to LibreOffice Calc file
3.Click the formula bar
4.Paste the text

Actual Results:  
Cell's format is changed to Times New Roman

Expected Results:
Original cell format should not be changed (as in Microsoft Excel)


Reproducible: Always


User Profile Reset: No



Additional Info:
It must be Text-Only


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Buovjaga 2017-11-26 19:31:39 UTC
I can reproduce in 5.4.3, but it seems to be fixed in 6.0
Could you try a daily build to see, if it works for you: https://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/current/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Arch Linux 64-bit
Version: 5.4.3.2
Build ID: 5.4.3-1
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit
Version: 6.0.0.0.alpha1+
Build ID: 008673c23db0c812eb0b48a1c29ab88b48aaa867
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on November 23rd 2017
Comment 2 gurol 2017-11-26 22:12:27 UTC
I can reproduce it in Version: 6.0.0.0.alpha1
By the way double clicking in a cell and pasting a formatted text should also behave like that (no formatting transfer) like in Excel. I found this feature very useful.
Comment 3 Alex Thurgood 2017-11-27 09:55:58 UTC
I can confirm the copy/paste behaviour with

Version: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Mac OS X 10.13.1; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

and with :

Version: 6.0.0.0.alpha1+
Build ID: 57c5f980835f834f6ea96c6f5ca841b5372aa61d
CPU threads: 4; OS: Mac OS X 10.13.1; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group



however, I am uncertain that this is a bug.

The default when copying formatted text from say, another document, e.g. Writer, to Calc (including the formula bar) appears to be to copy the font properties as well. 


This can be avoided by using :

Shift-Cmd-V and choosing "Unformatted Text" as the paste option.

It appears that this behaviour is LibreOffice application wide. I don't know whether a change  can be made to render what you want Calc-specific or not.

Setting to NEW as I can reproduce, but I'll leave it to others to decide whether this is in fact a bug, or expected behaviour. It may just be one area where we differ from how Calc behaves with respect to Excel.
Comment 4 Buovjaga 2017-11-27 10:06:19 UTC
(In reply to Alex Thurgood from comment #3)
> Setting to NEW as I can reproduce, but I'll leave it to others to decide
> whether this is in fact a bug, or expected behaviour. It may just be one
> area where we differ from how Calc behaves with respect to Excel.

I want to emphasise that as of 6.0, this is apparently exclusive to macOS. Windows and Linux do not transfer the formatting. Both did in 5.4.

Version: 6.0.0.0.alpha1+ (x64)
Build ID: a0ebba3d8855fee0bcec04a10137ae3a4f9f0e77
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-11-22_05:59:17
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 5 Maxim Monastirsky 2018-09-02 18:02:22 UTC
Pasting in the formula bar doesn't retain formatting since 6.1/6.0.5. See Bug 117017 comment 12. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 117017 ***