Download it now!
Bug 114054 - Weird orientation shift on printing letter size documents in Write
Summary: Weird orientation shift on printing letter size documents in Write
Status: RESOLVED DUPLICATE of bug 92190
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.7.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-25 22:09 UTC by Phil Pesek
Modified: 2017-11-26 03:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of problem (149.15 KB, image/jpeg)
2017-11-25 22:13 UTC, Phil Pesek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Pesek 2017-11-25 22:09:45 UTC
Description:
As discussed in the forum posts below, there is a bug numerous people are experiencing printing US Letter-size Writer documents on MacOS.  Changing the dimensions to 8.5x10.99 or the like fixes the problem (but it is rather frustrating until you find that fix which is not necessarily intuitive).  It appears to happen on both 5.3.7 and 5.4.2 at least.

https://ask.libreoffice.org/en/question/88250/printing-page-orientation-wrong-in-os-x/

Steps to Reproduce:
1. Create new document or open an existing one that is Letter page size.
2. Put some text in it
3. Select print from the menu and the preview image will show the problem.

Actual Results:  
Text is oriented at a 90 degree angle (off to its side) and cut off.

Expected Results:
Normal printing.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Phil Pesek 2017-11-25 22:13:07 UTC
Created attachment 137989 [details]
Screenshot of problem
Comment 2 Phil Pesek 2017-11-25 22:13:21 UTC
See attached screenshot
Comment 3 Phil Pesek 2017-11-25 22:21:17 UTC
The problem appears to be Mac-specific.  The same file on Ubuntu 16.04 behaves correctly.
Comment 4 V Stuart Foote 2017-11-26 03:11:35 UTC
target:6.0.0 target:5.4.4

https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-4&id=9f8429d81c08cc40d5b1210cb6e4b383316cdc75

*** This bug has been marked as a duplicate of bug 92190 ***