Bug 114071 - Changing the offset of a 'Page Number' field to a value greater or equal to 18 makes the page number disappear
Summary: Changing the offset of a 'Page Number' field to a value greater or equal to 1...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Page-Number
  Show dependency treegraph
 
Reported: 2017-11-26 18:02 UTC by Wagner Schalch Mendes
Modified: 2017-11-26 18:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document where the problem is being perceived (640.12 KB, application/vnd.oasis.opendocument.text)
2017-11-26 18:04 UTC, Wagner Schalch Mendes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wagner Schalch Mendes 2017-11-26 18:02:50 UTC
Description:
I have a document, in which I want to set an offset of 18 to the page numbers. The first page has an style different from the others, so I need to apply this offset to the first and second pages. For some strange reason, the 17th page, which should be the page '35' with the offset equal to 18 simply lose the page number when the offset is applied. Offsets smaller than 18 works fine.

Steps to Reproduce:
1. Open the attached document.
2. Go to the footer of the second page where there is a field for the page number, double-click on the field and add an offset of '18'.
3. Go to the 17th page (which should be the number '35' after offset has been applied) and check that the page number disappeared. The field is still there, but it seems to be empty.
4. Go to the previous page and check that the page number is still there.
5. Apply an offset smaller than '18' and check that the problem doesn't happen.

Actual Results:  
The page number of the 17th page disappear, even though the 'Page Number' field is still there.

Expected Results:
Field 'Page Number' of the 17th page should be displaying '35'.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063
Comment 1 Wagner Schalch Mendes 2017-11-26 18:04:41 UTC
Created attachment 137995 [details]
Document where the problem is being perceived
Comment 2 Dieter 2017-11-26 18:30:17 UTC
Using your document I could confirm, that there is something wrong, but my observation is a little bit different:

I used different numbers for offset. In every case, number 34 was the last page number that was printed. For example if you choose offset = 9, the last nine pages had no page number (although the field was there).
Comment 3 Mike Kaganski 2017-11-26 18:44:24 UTC
This is expected. The offset value is not designed to modify the "current page number"; instead, it is meant to show the number of page that is offset from current by defined number (i.e., you are showing the number of page that is "N pages forward from this page"). Naturally, it cannot show you the number of page that is not in current document.

What you are trying to do is to change the number of current page. This is done in the page break properties (first page's paragraph properties), where you can define the page number. This not only avoids the "problem" you see here, but also ensures you have proper page numbers in cross references, like ToC and other references.

See https://wiki.documentfoundation.org/Faq/Writer#Page_Numbering for reference.

Closing NOTABUG.