Bug Hunting Session
Bug 114075 - EDITING: Alphabetical Index insertion crashes LibreOffice
Summary: EDITING: Alphabetical Index insertion crashes LibreOffice
Status: RESOLVED DUPLICATE of bug 113284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-26 20:12 UTC by Emanuele Gissi
Modified: 2017-11-26 20:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuele Gissi 2017-11-26 20:12:01 UTC
Description:
1) Open a new writer document
2) Insert > Table of contents and Index > Table of contents...
3) Select: Type > Alphabetical Index and push OK
4) LibreOffice crashes. This messagebox is shown:

wrapped std::eception vector::_M_range_check:__n (which is 0) >= this->size() (which is 0)

I need an Alphabetical Index! 
Thank you very much for your kind work.

Steps to Reproduce:
1) Open a new writer document
2) Insert > Table of contents and Index > Table of contents...
3) Select: Type > Alphabetical Index and push OK
4) LibreOffice crashes. This messagebox is shown:

wrapped std::eception vector::_M_range_check:__n (which is 0) >= this->size() (which is 0)


Actual Results:  
LibreOffice crashes

Expected Results:
Insertion of Alphabetical Index


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
None


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36
Comment 1 Aron Budea 2017-11-26 20:39:38 UTC
The fix will come as part of 5.4.4.

*** This bug has been marked as a duplicate of bug 113284 ***