Bug 114098 - Adress-source - Field assignment : Dialog is not user friendly
Summary: Adress-source - Field assignment : Dialog is not user friendly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.1.0 target:6.0.0.1 target:5.4.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-11-27 16:19 UTC by Thomas Krumbein
Modified: 2017-12-09 21:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
actual dialog (11.40 KB, image/png)
2017-11-27 16:21 UTC, Thomas Krumbein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Krumbein 2017-11-27 16:19:46 UTC
Description:
We do have a dialog to assign fields of the selected Adress-Source to internal fields.
This Dialog does not fit to any user friendliness and should be reworked.



Steps to Reproduce:
1. select an adress source: Menu File - wissards - Adress-Source
2. Select a "other datasource" - for example a simple calc-sheet
3. Then you should assign the Adress-fields to internal fields. Nessasary and ok.
(see picture_1)

The dialog shows 10 fields to assign - in reallity there are much more fields - I guess in sum more than 25 fields. no hint in the dialog. 
 

Actual Results:  
see picture 1. 

the normal user do not know, that there are around 15 additional fields to assign, not only those 10 he can see!
He will run in errors or problems during later use, if he does not assign all fields.


Expected Results:
if the dialog can not show all fields, the dialog should have an scroll-bar or some hints, that a user should scroll through the fields and that there are more than appears.


Reproducible: Always


User Profile Reset: No



Additional Info:
bad or wrong UI design.  Never changed since OOo times.

Picture is result of Windows 10, 64 bit - LO 6.0.0.0.Beta1 - but same behavieor in all prio versions.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Thomas Krumbein 2017-11-27 16:21:14 UTC
Created attachment 138020 [details]
actual dialog

it is not visible, that there are more than 20 fields to assign. Scrolling is possible - but you must know it.
Comment 2 Xisco Faulí 2017-11-27 18:47:44 UTC
Regression introduced by:

author	Adolfo Jayme Barrientos <fitojb@ubuntu.com>	2014-11-09 02:03:13 (GMT)
committer	Samuel Mehrbrodt <s.mehrbrodt@gmail.com>	2014-11-09 11:25:36 (GMT)
commit	418eeaa91f4539ef4ce8a832f8b08f14ffd7fe75 (patch)
tree	20975db2268548d65f3dd359abc56caf98bf8e26
parent	e6a0e5069fc18edca3ce01d87565b8ab728c008d (diff)
fdo#86050 Let LibreOffice add scrollbars to widgets only when necessary

bisected with: bibisect-44max

Adding Cc: to Adolfo Jayme Barrientos
Comment 3 Xisco Faulí 2017-12-01 16:00:40 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/45686/
Comment 4 Commit Notification 2017-12-01 16:20:55 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=be40df24b26827057e5303b612196a3ded84bebd

tdf#114098 Show vertical scrollbar

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-12-01 18:57:41 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eed2c5d7fc7e96a06bf5862f023f08f5e2446343&h=libreoffice-6-0

tdf#114098 Show vertical scrollbar

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-12-09 21:02:56 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30f399a631cae8060cbfb8bde87ecaadcdf4f406&h=libreoffice-5-4

tdf#114098 Show vertical scrollbar

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.