Bug 114131 - Inserting new rows/columns not disabled in read-only spreadsheet when right-clicking on rows or columns
Summary: Inserting new rows/columns not disabled in read-only spreadsheet when right-c...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.2.0 target:6.1.0.2 target:6.0.6
Keywords:
: 118650 (view as bug list)
Depends on:
Blocks: Read-Only Cell-Add-Delete
  Show dependency treegraph
 
Reported: 2017-11-29 10:30 UTC by Laurent Bigonville
Modified: 2018-07-09 20:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bigonville 2017-11-29 10:30:45 UTC
Hi,

When opening a spreadsheet read-only (opening it from Thunderbird for example) the ability to add new lines/columns is not disabled.

OTOH, the functions to remove lines is well disabled
Comment 1 Buovjaga 2017-12-03 13:39:27 UTC
Not reproduced.

Which operating system are you using?

Version: 6.1.0.0.alpha0+ (x64)
Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-03_00:59:10
Locale: fi-FI (fi_FI); Calc: group threaded

Arch Linux 64-bit
Version: 5.4.3.2
Build ID: 5.4.3-1
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Laurent Bigonville 2017-12-03 14:15:13 UTC
I'm running an up2date debian unstable

GTK3 widgets

Version: 5.4.3.2
Build ID: 1:5.4.3-3
Threads CPU : 8; OS : Linux 4.13; UI Render : par défaut; VCL : gtk3; 
Locale : fr-BE (fr_BE.UTF-8); Calc: group
Comment 3 Buovjaga 2017-12-03 14:29:44 UTC
Now I tried with GTK3 but they are still disabled for me.
Comment 4 Laurent Bigonville 2017-12-03 14:42:48 UTC
I can reproduce that easily:

 - Create a spreadsheet, put some data, save it in /tmp/test.ods
 - chmod 444 /tmp/test.ods
 - libreoffice /tmp/test.ods

There is a banner on the top telling the file is R/O

Right click on the column/line header (be sure the column/line is being completely selected), the contextual menu shows 3 entries, Copy, Insert line (above/left), insert line (bellow/right)
Comment 5 Buovjaga 2017-12-03 14:46:05 UTC
Ok, with the correct steps I can repro.

Arch Linux 64-bit
Version: 5.4.3.2
Build ID: 5.4.3-1
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 6 Xisco Faulí 2018-07-06 22:22:19 UTC
Patch submitted to gerrit: https://gerrit.libreoffice.org/#/c/57098/
Comment 7 Commit Notification 2018-07-09 15:42:55 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1407aeea58046e0ab5e2483dbc5984ee1c0f4187

tdf#114131 Remove insert rows/columns in read-only mode

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-07-09 17:09:16 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4af596e062f694690a07b4b7901965f119aad1cc&h=libreoffice-6-1

tdf#114131 Remove insert rows/columns in read-only mode

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-07-09 19:32:35 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48073e1601b14563439c6505f6888921598a4cc5&h=libreoffice-6-0

tdf#114131 Remove insert rows/columns in read-only mode

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Roman Kuznetsov 2018-07-09 20:09:36 UTC
*** Bug 118650 has been marked as a duplicate of this bug. ***