Download it now!
Bug 114149 - LibreOffice does not display self set icons in own toolbars, only text is displayed
Summary: LibreOffice does not display self set icons in own toolbars, only text is dis...
Status: RESOLVED DUPLICATE of bug 106784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.7.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-29 18:22 UTC by bugzilla
Modified: 2018-06-24 23:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2017-11-29 18:22:58 UTC
Description:
I use macros and an own toolbar for that. Each macro (only text and backgroundcolor changes) has its own 24x24 png icon. I wanted to add an extra macro and add an icon. I can see the imported icon in the customize toolbar menu, but in the toolbar itself only the macro name is shown.

Steps to Reproduce:
1. Record Macro
2. Set new toolbar
3. Add command
4. Modify
5. Change Icon
6. Import Icon
7. OK
8. Set Style "Icons"

Actual Results:  
In the "Customize" toolbar menu you can see the icon.
The toolbar itself displays alsways command text.

Expected Results:
The toolbar should display command icon.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
This also happens with LibreOffice 5.4.3.2
In 5.1.0.3 this bug is not present and the icons are displayed (and added) fine.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.3.5 (KHTML, like Gecko) Version/11.0.1 Safari/604.3.5
Comment 1 Alex Thurgood 2017-11-30 08:33:27 UTC
Hi,

For an example of how to integrate icons into custom toolbars, it might be better to check out how this is done via an extension. See for example the DMaths add-on, which comes with its own sets of custom toolbars:

https://www.dmaths.org/
Comment 3 Alex Thurgood 2017-12-01 08:45:48 UTC
Awaiting return of information from original poster on trying Regina's suggestion.

Setting to NEEDINFO pending that information, but jduging by the description referred to in Regina's link this should be WORKSFORME or INVALID.
Comment 4 QA Administrators 2018-05-30 16:40:00 UTC Comment hidden (obsolete)
Comment 5 Maxim Monastirsky 2018-06-24 23:19:52 UTC

*** This bug has been marked as a duplicate of bug 106784 ***