Bug Hunting Session
Bug 114161 - FILESAVE XLSX Custom colors of Data Points are not preserved when the spreasheet is saved as XLSX
Summary: FILESAVE XLSX Custom colors of Data Points are not preserved when the spreash...
Status: RESOLVED DUPLICATE of bug 96469
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-30 08:42 UTC by Gabor Kelemen
Modified: 2017-11-30 10:37 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example file made with Excel 2013 (19.10 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-30 08:42 UTC, Gabor Kelemen
Details
The example file saved by LO6 alpha (17.02 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-30 08:43 UTC, Gabor Kelemen
Details
The two files in Calc and Excel side by side (144.77 KB, image/png)
2017-11-30 08:45 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-11-30 08:42:50 UTC
Created attachment 138105 [details]
Example file made with Excel 2013

Custom colors of Data Points in Excel 2013 made charts are not preserved when the spreadsheet is saved as XLSX in LibreOffice Calc.

Steps to reproduce:
1. Create a new spreadsheet in Microsoft Excel 2013.
2. Create a simple chart (a column chart with default settings will do) with the default values.
3. Change the color of a Data Point.
4. Save the file as XLSX.
5. Open the file with LibreOffice Calc and save it with a different name as XLSX.

Actual results:
The data points revert to the default color.

Expected results:
The custom color of the data points should be preserved.
Comment 1 Gabor Kelemen 2017-11-30 08:43:10 UTC
Created attachment 138106 [details]
The example file saved by LO6 alpha
Comment 2 Gabor Kelemen 2017-11-30 08:45:11 UTC
Created attachment 138107 [details]
The two files in Calc and Excel side by side
Comment 3 Jacques Guilleron 2017-11-30 10:37:56 UTC
Hi Gabor,

Colors not preserved with Xlsx export was previously reported in
Bug 96469 - FILESAVE: Data Point Color in Charts lost on DOCX/XLSX export
Therefore I set Status to Duplicate.

*** This bug has been marked as a duplicate of bug 96469 ***