Bug 114168 - FILEOPEN XLSX XLS Bar Chart minor axis spacing appears differently than the Microsoft Office minor axis spacing
Summary: FILEOPEN XLSX XLS Bar Chart minor axis spacing appears differently than the M...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:6.1.0 target:6.0.4
Keywords: filter:xlsx
Depends on:
Blocks:
 
Reported: 2017-11-30 11:08 UTC by Gabor Kelemen
Modified: 2018-04-07 09:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file made with Excel 2013 (20.82 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-30 11:08 UTC, Gabor Kelemen
Details
The example file saved by LO6 alpha (16.78 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-30 11:08 UTC, Gabor Kelemen
Details
The two files in Calc and Excel side by side (112.47 KB, image/png)
2017-11-30 11:09 UTC, Gabor Kelemen
Details
Example .xlsx file where Minor and Major Units are set to automatic (17.31 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-02-07 01:14 UTC, Bartosz
Details
Example .xls file with default minor and major axis (37.00 KB, application/x-ole-storage)
2018-02-07 01:24 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-11-30 11:08:31 UTC
Created attachment 138115 [details]
Example file made with Excel 2013

We create a simple Bar chart in Microsoft Office Excel and we set the minor scale to show outside on the axis. In Microsoft Office Excel we can set the unit of the minor scale, so the spacing will be displayed by the unit of minor scale. In LibreOffice we cannot set the unit of minor scale, but we can set the minor interval count. This two different setting option the reason for the two different appearance.

Steps to reproduce:
1. Create a new spreadsheet in Microsoft Excel.
2. Add values to a few cells.
3. Select the cell range that contains the data.
4. Create a simple Bar chart in Microsoft Excel.
5. Click on the Y axis to setting the spacing.
5. Set the minor interval unit (if the main scale “1000” you should set “200” for the minor scale: in this case, it divides the main scale into five parts) and the minor scale to show outside on the axis.
6. Save it as XLSX and close the file. 
7. Open the file in LibreOffice Calc and compare the Y axis scales.

Actual results:
As you can see in LibreOffice Calc the main scale was divides into two parts. In the Y Axis scale option you can see that Minor interval count is “2”.

Expected results:
The minor interval count should be the same in Microsoft Office Excel and LibreOffice Calc.
Comment 1 Gabor Kelemen 2017-11-30 11:08:59 UTC
Created attachment 138116 [details]
The example file saved by LO6 alpha
Comment 2 Gabor Kelemen 2017-11-30 11:09:19 UTC
Created attachment 138117 [details]
The two files in Calc and Excel side by side
Comment 3 Buovjaga 2017-12-03 14:28:30 UTC
Confirmed.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-03_00:59:10
Locale: fi-FI (fi_FI); Calc: group threaded

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Bartosz 2018-02-07 01:14:02 UTC
Created attachment 139647 [details]
Example .xlsx file where Minor and Major Units are set to automatic
Comment 5 Bartosz 2018-02-07 01:24:22 UTC
Created attachment 139648 [details]
Example .xls file with default minor and major axis
Comment 6 Bartosz 2018-02-07 02:02:05 UTC
I'm afraid that implementing full support of Minor axis as it was implemented in MS Excel will require a lot of efford.
With this review, I have fixed automatic behaviour of minor axis spacing:
https://gerrit.libreoffice.org/#/c/49327/
Comment 7 Commit Notification 2018-02-08 07:08:57 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=274825b4180c81540cd0d1b22c5243f1b39fe4db

tdf#114168 If minor axis unit is automatic, then set it to 5

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-04-07 09:39:29 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40e722fd44e3cf026e1aee2b2c2c97eb57b53468&h=libreoffice-6-0

tdf#114168 If minor axis unit is automatic, then set it to 5

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.