Bug Hunting Session
Bug 114174 - FILESAVE XLSX Many custom chart legend properties are not preserved when the spreadsheet is saved as XLSX
Summary: FILESAVE XLSX Many custom chart legend properties are not preserved when the ...
Status: RESOLVED DUPLICATE of bug 108078
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2017-11-30 13:17 UTC by Gabor Kelemen
Modified: 2018-10-10 14:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file made with Calc (48.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-30 13:17 UTC, Gabor Kelemen
Details
The example file saved by LO6 alpha in XLSX (43.49 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-30 13:18 UTC, Gabor Kelemen
Details
The example files in Calc side by side (148.48 KB, image/png)
2017-11-30 13:18 UTC, Gabor Kelemen
Details
Example file made with Excel 2013 (203.73 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-12-04 13:40 UTC, Gabor Kelemen
Details
The Excel-made example saved in LO6 alpha (44.07 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-12-04 13:44 UTC, Gabor Kelemen
Details
Example .xlsx file created by Office 2013, with legend with gradient (18.79 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-01-06 06:13 UTC, Bartosz
Details
Example file with gradients in legend, PlotArea, Chart and axis created with MS Office 2013 (11.64 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-07-22 00:57 UTC, Bartosz
Details
Example file with patterns in legend, PlotArea, Chart and axis created with MS Office 2013 (11.62 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-07-22 01:34 UTC, Bartosz
Details
Example XLS file with patterns in legend, PlotArea, Chart and axis created with MS Office 201 (35.00 KB, application/vnd.ms-excel)
2018-07-22 01:47 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-11-30 13:17:41 UTC
Created attachment 138131 [details]
Example file made with Calc

Many Chart Legend properties are not preserved when the spreadsheet is saved as XLSX, including Gradient, Bitmap, Pattern and Hatch area fills, transparencies with gradient and border line styles different from Continuous. The custom size of the chart legend isn't preserved either, but that's a different bug.

Steps to reproduce:
1. Create a new spreadsheet in LibreOffice Calc.
2. Create a simple chart (a column chart with default settings will do) based on any values.
3. Change the area fill of the chart legend to bitmap, pattern, hatch, transparent with gradient, or the Border line style to something different from Continuous.
4. Save the file as XLSX.
5. Reload the file.

Actual results:
The custom chart legend property will be lost.

Expected results:
The custom chart legend property should be preserved.
Comment 1 Gabor Kelemen 2017-11-30 13:18:00 UTC
Created attachment 138132 [details]
The example file saved by LO6 alpha in XLSX
Comment 2 Gabor Kelemen 2017-11-30 13:18:49 UTC
Created attachment 138133 [details]
The example files in Calc side by side
Comment 3 Buovjaga 2017-12-03 14:44:02 UTC
Repro.

Just a check: you did test in MS Excel that it supports creating this stuff?

Version: 6.1.0.0.alpha0+ (x64)
Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-03_00:59:10
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 4 Gabor Kelemen 2017-12-04 13:40:27 UTC
Created attachment 138213 [details]
Example file made with Excel 2013

Similar example file from Excel.
Comment 5 Gabor Kelemen 2017-12-04 13:44:35 UTC
Created attachment 138214 [details]
The Excel-made example saved in LO6 alpha

If we set a few chart legend properties in Excel, then open the file and save it in LO, we get:
- Solid color and border roudtrips fine
- Gradient, bitmap, pattern, image, transparency+gradient opens fine, but disappears after saving.
Comment 6 Bartosz 2018-01-06 06:13:43 UTC
Created attachment 138912 [details]
Example .xlsx file created by Office 2013, with legend with gradient
Comment 7 Xisco Faulí 2018-05-31 08:44:10 UTC Comment hidden (obsolete)
Comment 8 Bartosz 2018-07-22 00:57:17 UTC
Created attachment 143679 [details]
Example file with gradients in legend, PlotArea, Chart and axis created with MS Office 2013
Comment 9 Bartosz 2018-07-22 01:34:08 UTC
Created attachment 143680 [details]
Example file with patterns in legend, PlotArea, Chart and axis created with MS Office 2013
Comment 10 Bartosz 2018-07-22 01:47:47 UTC
Created attachment 143681 [details]
Example XLS file with patterns in legend, PlotArea, Chart and axis created with MS Office 201
Comment 11 Bartosz 2018-10-10 14:56:27 UTC

*** This bug has been marked as a duplicate of bug 108078 ***