Bug 114208 - Allow selection of PDF page upon inserting as image
Summary: Allow selection of PDF page upon inserting as image
Status: RESOLVED DUPLICATE of bug 114234
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-02 13:23 UTC by Alex
Modified: 2018-08-05 12:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2017-12-02 13:23:16 UTC
Description:
Currently when importing/linking PDF files only first page is displayed. Input box with page number inside image options is needed to set page number of imported file.

Steps to Reproduce:
Import/link any multipage PDF file.

Actual Results:  
Only first page can be imported/linked

Expected Results:
Possibility to set page number of multipage PDF


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Dieter 2017-12-02 18:12:37 UTC
> Steps to Reproduce:
> Import/link any multipage PDF file.

Can you provide more detailed steps, how you import the file? I tried the following:

1. Open writer
2. File => Open
3. Open a multipage PDF-file
4. PDF-file is opened in DRAW (I tested with a PDF-file of three pages and it worked)


Version: 6.0.0.0.beta1 (x64)
Build ID: 97471ab4eb4db4c487195658631696bb3238656c
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group threaded
Comment 2 Alex 2017-12-03 12:41:29 UTC
I've linked PDF as image into Writer using Insert>Image, just like any other jpg or png.
Comment 3 Buovjaga 2017-12-03 16:50:23 UTC
Yep

Version: 6.1.0.0.alpha0+ (x64)
Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-03_00:59:10
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 4 Dieter 2017-12-03 20:04:29 UTC
Since an image never has more than one page, I wouldn't expect that more than the first page of a PDF-file is shown.
Comment 5 Alex 2017-12-03 20:18:59 UTC
Tiff files can have multiple pages, so PDF and TIFF are exeptions. Scribus has got option inside Image Options to select page for PDF, not sure if it works for tiff.
Comment 6 Yousuf Philips (jay) (retired) 2017-12-04 10:44:31 UTC

*** This bug has been marked as a duplicate of bug 114234 ***