Bug 114222 - EMF Files look distorted in LOdev6.0beta1 but good in LO5.3.7
Summary: EMF Files look distorted in LOdev6.0beta1 but good in LO5.3.7
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2017-12-03 11:09 UTC by Joerg
Modified: 2017-12-04 07:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
TestDocCreatedWithLO537.odt (35.17 KB, application/vnd.oasis.opendocument.text)
2017-12-03 11:10 UTC, Joerg
Details
ScreenshotOfTestDocInLO60beta1_broken.PNG (131.14 KB, image/png)
2017-12-03 11:10 UTC, Joerg
Details
ScreenshotOfTestDocInLO537_correct.PNG (137.54 KB, image/png)
2017-12-03 11:11 UTC, Joerg
Details
screenshot (zoom in to 120%) (24.32 KB, image/jpeg)
2017-12-03 20:18 UTC, Dieter Praas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg 2017-12-03 11:09:22 UTC
Description:
I created a test document with LibreOffice-Windows 5.3.7.2 (x64) Build-ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059

The test document contains nothing than two embedded EMF graphics

This looks as expected if I open it in LO5.3.7 again.

But if I open it in LibreOfficeDev-Windows: 6.0.0.0.beta1+ Build ID: 95f643cd9c14f3eb8ca3a265d0d0ea8f4b7c8865
the document looks distorted.

See the attached screenshots.

Steps to Reproduce:
Open the attached test document in LO5.3.7 and LOdev6.0beta1 and compare how it looks on screen

Actual Results:  
Distorted rendering to screen with LOdev6.0beta1

Expected Results:
Same rendering quality as in LO5.3.7


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Joerg 2017-12-03 11:10:20 UTC
Created attachment 138190 [details]
TestDocCreatedWithLO537.odt
Comment 2 Joerg 2017-12-03 11:10:57 UTC
Created attachment 138191 [details]
ScreenshotOfTestDocInLO60beta1_broken.PNG
Comment 3 Joerg 2017-12-03 11:11:28 UTC
Created attachment 138192 [details]
ScreenshotOfTestDocInLO537_correct.PNG
Comment 4 Buovjaga 2017-12-03 17:23:41 UTC
No problem here.

Please include the contents of your help - about like below

Version: 6.1.0.0.alpha0+ (x64)
Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-03_00:59:10
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 5 Joerg 2017-12-03 17:25:10 UTC
The affected version is:
Version: 6.0.0.0.beta1+
Build ID: 95f643cd9c14f3eb8ca3a265d0d0ea8f4b7c8865
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:libreoffice-6-0, Time: 2017-12-01_04:31:12
Locale: de-DE (de_DE); Calc: group threaded
Comment 6 Dieter Praas 2017-12-03 20:17:07 UTC
Tested with

Version: 5.4.3.2 (x64)
Build-ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: it-IT (de_DE); Calc: group

and

Version: 6.0.0.0.beta1 (x64)
Build ID: 97471ab4eb4db4c487195658631696bb3238656c
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group threaded

I confirm the bug (see screenshot in next comment), but it only happened, with "Zoom in"
Comment 7 Dieter Praas 2017-12-03 20:18:09 UTC
Created attachment 138197 [details]
screenshot (zoom in to 120%)
Comment 8 Xisco Faulí 2017-12-03 20:29:40 UTC
I guess it's the same as bug 114076

*** This bug has been marked as a duplicate of bug 114076 ***
Comment 9 Joerg 2017-12-03 22:39:41 UTC
As the original reporter of this bug I reopen it, because it's not about white lines as in the screenshot from dieter Prass and therefore it is not a duplicate of #114076.

Please have a second look at the distorted text in the screenshot attached by me.
Comment 10 Dieter Praas 2017-12-04 06:57:35 UTC
I confirmed your bug, because my result fits the bug summary: "EMF Files look distorted in LOdev6.0beta1 but good in LO5.3.7". Perhaps you should precise the bug summary.
Comment 11 Joerg 2017-12-04 07:48:37 UTC
I close this bug, because I found out, that the reason was just disabled Antialiasing. After enabling it in the Options the document looked fine.