Bug 114285 - FILEOPEN XLSX Rotation in 3D Column chart labels in Excel made XLSX files is wrong when opened in LibreOffice.
Summary: FILEOPEN XLSX Rotation in 3D Column chart labels in Excel made XLSX files is ...
Status: RESOLVED DUPLICATE of bug 108031
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-06 16:21 UTC by Gabor Kelemen
Modified: 2017-12-23 09:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file made with Excel 2013 (19.83 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-12-06 16:21 UTC, Gabor Kelemen
Details
Screenshot of the document in LO 6 and Excel 2013 (435.18 KB, image/png)
2017-12-06 16:21 UTC, Gabor Kelemen
Details
The example file saved by LO6 alpha (17.04 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-12-06 16:22 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-12-06 16:21:39 UTC
Created attachment 138248 [details]
Example file made with Excel 2013

If we create a 3D Column chart in Microsoft Excel 2013/2016 the default setting of label rotation will be horizontal. Even if the labels are too long to fit, the Microsoft Excel automatically rotate the labels in the most optimal way (vertical or -45°). When we open the spreadsheet in LibreOffice the X category axis label will be vertical (which is the same as the MSO Excel default rotation setting), even if it doesn’t fit.

Steps to reproduce:
1. Create a new spreadsheet in Excel 2013.
2. Create a simple 3D Column chart.
3. The X category Axis labels should be properly long strings, so the MSO Excel will rotate the labels automatically. Or you can resize the chart area and the MSO Excel will automatically rotate the labels.
4. Click right on the diagram, and select the 3-D rotation.
5. Remove the mark from the “Right Angle Axis”.
5. Save the file and close Excel.
6. Open the same file with LibreOffice Calc.

Actual results:
The chart label isn't rotated anymore, because the default rotation setting is horizontal and the “Right Angle Axis” option was not checked.

Expected results:
The chart label should stay rotated.

***************************************
In LibreOfficeDev Calc
Version: 6.0.0.0.beta1+
Build ID: 29228e83df009cf76ac819ed024527be1092f065
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:libreoffice-6-0, Time: 2017-12-04_23:15:34
Locale: hu-HU (hu_HU); Calc: group threaded

7. Open the original file with LibreOfficeDev Calc save as the file in xlsx.
8. Reload the spreadsheet.

Actual results:
The X axis label is disappeared.

Expected results:
The x axis label should not be disappeared.
Comment 1 Gabor Kelemen 2017-12-06 16:21:57 UTC
Created attachment 138249 [details]
Screenshot of the document in LO 6 and Excel 2013
Comment 2 Gabor Kelemen 2017-12-06 16:22:41 UTC
Created attachment 138250 [details]
The example file saved by LO6 alpha
Comment 3 Jacques Guilleron 2017-12-07 15:48:06 UTC
Hi Gabor,

I reproduce the not rotated labels with
LO 6.1.0.0.alpha0+ Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-02_23:45:34
Locale: fr-FR (fr_FR); Calc: CL
I don't reproduce the labels disapearring after saving.
But to do it clearly, this should be report in an other report, since this is a
different issue.
Comment 4 JoNi 2017-12-23 09:46:11 UTC

*** This bug has been marked as a duplicate of bug 108031 ***