Bug Hunting Session
Bug 114297 - [Notebookbar] [Groupedbar] Add connectors dropdown button to the interface
Summary: [Notebookbar] [Groupedbar] Add connectors dropdown button to the interface
Status: RESOLVED DUPLICATE of bug 79356
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2017-12-07 03:14 UTC by Bastián Díaz
Modified: 2017-12-21 12:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
"connector" dropdown in "drawing" toolbar (51.55 KB, image/png)
2017-12-09 10:23 UTC, sindarus
Details
screenshot (174.78 KB, image/png)
2017-12-20 19:52 UTC, Bastián Díaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2017-12-07 03:14:58 UTC
Description:
Currently there is no way to add connectors easily from the interface or the corresponding menu (full/compact).

Steps to Reproduce:
1. See in the drawing area
2. See in the draw menu
3. Add a flowchart shape and search in the new context available options

Actual Results:  
There is no way to add connectors

Expected Results:
A connectors dropdown button is available in the interface or in the Draw menu


Reproducible: Always


User Profile Reset: No



Additional Info:
Suggested solution: I would expect to see connectors dropdown button instead of curve. I have no usage data to support me, but from experience I think that connectors are a more used element (diagrams). Additionally the options available in the curve dropdown button are already in the "draw" menu.

Note: The inclusion of the options "insert image" and "fontwork ..." in the Draw menu is by design?


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 sindarus 2017-12-09 10:23:53 UTC Comment hidden (obsolete)
Comment 2 sindarus 2017-12-09 10:25:32 UTC Comment hidden (obsolete)
Comment 3 sindarus 2017-12-09 10:44:44 UTC Comment hidden (obsolete)
Comment 4 Bastián Díaz 2017-12-20 19:52:16 UTC
Created attachment 138555 [details]
screenshot

Additional Info:

Many other applications use a combined dropdown menu, commonly mixing lines, arrows and connectors. In the case of LibreOffice, something similar could be done for interfaces that use NotebookBar.
Comment 5 Yousuf Philips (jay) (retired) 2017-12-21 12:01:40 UTC
This isnt limited to the notebookbar, the connector slit button isnt available in writer in calc.

*** This bug has been marked as a duplicate of bug 79356 ***