Bug 114305 - Writer does not handle changes with D'n'd text move in .docx format
Summary: Writer does not handle changes with D'n'd text move in .docx format
Status: RESOLVED DUPLICATE of bug 104797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Track-Changes DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2017-12-07 10:44 UTC by Gabor Kelemen
Modified: 2018-07-24 09:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file made with Word 2013 containing d'n'd moved text (21.45 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-12-07 10:44 UTC, Gabor Kelemen
Details
The example file in Writer 5.4 and Word 2013 side by side (71.93 KB, image/png)
2017-12-07 10:44 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-12-07 10:44:07 UTC
Created attachment 138269 [details]
Example file made with Word 2013 containing d'n'd moved text

LO does not recognise the move as Change Tracking operation, and displays the moved text both in the original and in the new places.

Steps to reproduce:
1. Create a new document with 3 paragraph in MS Word.
2. Record Track Changes.
3. Drag the first paragraph and drop it in the third paragraph.
4. Save this document in .docx format.
5. Open this document with LibreOffice Writer version 5.4.1.2.
6. Open the Manage Changes window.

Actual results:
LO does not list any changes, but lists the moved paragraph both in the original and in the new places.

Expected results:
LO lists the change in Manage Changes window.
LO marks the deleting of the moved text in original place.
LO marks the inserted text in new place.
User can accept or reject the change in one step.
Comment 1 Gabor Kelemen 2017-12-07 10:44:57 UTC
Created attachment 138270 [details]
The example file in Writer 5.4 and Word 2013 side by side
Comment 2 Yousuf Philips (jay) (retired) 2017-12-09 15:51:33 UTC
Assume that LO doesnt understand the <w:moveFromRangeStart>, <w:moveFromRangeEnd>, <w:moveToRangeStart>, <w:moveToRangeEnd> or possibly it doesnt get it them in this scenario when <w:moveFromRangeStart> and <w:moveToRangeStart> are inside of a <w:p>.

Justin: thoughts?
Comment 3 Timur 2017-12-29 17:04:17 UTC
*** Bug 101580 has been marked as a duplicate of this bug. ***
Comment 4 Buovjaga 2018-01-29 10:35:45 UTC

*** This bug has been marked as a duplicate of bug 104797 ***