Bug Hunting Session
Bug 114335 - Field dialog: Add possibility to set default format
Summary: Field dialog: Add possibility to set default format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1 all versions
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Dialog
  Show dependency treegraph
 
Reported: 2017-12-08 09:43 UTC by John Bester
Modified: 2017-12-09 08:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Bester 2017-12-08 09:43:01 UTC
Description:
Every time you insert a field (e.g. Date), the format defaults to the top format in the list - which is extremely irritating. I have a possible solution to this - see additional info.

Steps to Reproduce:
1. Open writer and select Insert / Field / More Fields ...
2. Under Document tab, select an entry such as "Date".

Actual Results:  
The first format in the list is the default when a field is created.

Expected Results:
The user should be able to select a default format for each type of field to be inserted. Also, these defaults should be defaulted to whatever the active locale suggests where possible.


Reproducible: Always


User Profile Reset: No



Additional Info:
Follow steps to reproduce. Select "Date" in the leftmost column as an example. You will see a list of possible formats in the rightmost column.
It would be absolutely great if you could select a specific format and then press a "Set as default" button below the list of formats. The next time a field of this type is added to the document, use this selected format when the field is inserted into the document. Obviously the user will still be able to change it.


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36
Comment 1 Dieter Praas 2017-12-08 10:43:40 UTC
It's not the case for eveay type:

Type: page => Format: As page style
Type: statistics => Format: As page style
Type: time => Format: [secon in the list]

So the default format is not always the first. So perhaps there is already the possibility to define a default format. But I couldn' find any informations within the help and a checkbox as you describe would be userfriendly.

Since I'm not sure about the actual setting, I added the keyword needsUXEval.
Comment 2 Heiko Tietze 2017-12-09 08:34:27 UTC
WORKSFORME as this is the standard behavior of (dropdown) lists. Resorting as we do for the font name is very uncommon and likely ends up in a mess. The same is true when you have something in mind as remembering the last used selection. 

However, our guideline [1] states to sort in a natural way and to have the most common option on top. 

* Place options that represent general options (e.g. all, none) at the beginning of the list.
* Sort list items in a logical order. Make sure sorting fits translation.
* Do not have blank list items; use meta-options, e.g. (None) instead

Which is the fact for the date field with YY/MM/DD for locale en_US and DD.MM.YY for de_DE. 

On the other hand I understand that it is tedious to not be able to use the shortcut Insert>Field>Date but always have to go through the dialog.

[1] https://wiki.documentfoundation.org/Design/Selection