Bug Hunting Session
Bug 114364 - MacOS: Opening an application from start center the first time after each launch is laggy
Summary: MacOS: Opening an application from start center the first time after each lau...
Status: RESOLVED DUPLICATE of bug 103892
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Performance
  Show dependency treegraph
 
Reported: 2017-12-09 12:55 UTC by Telesto
Modified: 2018-02-24 17:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Stack without symbols (10.70 KB, text/rtf)
2017-12-17 19:04 UTC, Telesto
Details
Screenshot (413.72 KB, image/png)
2017-12-17 19:05 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-12-09 12:55:27 UTC
Description:
Opening a application from the start center (Writer, Calc, Impress, Draw) the first after launching LibO is quite slow. Re-running the same application again is fast; Launching a different application for the first time (after opening - for example- writer) is also slow.  


Steps to Reproduce:
1. Launch LibreOffice
2. Open Writer (especially slow). Around 7 seconds before the empty document shows up 


Actual Results:  
It takes around 7 seconds

Expected Results:
Something similar to 4.3.7.2; Around 2 sec


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.1.0.0.alpha0+
Build ID: d46dc8e547810208287aab77f0313f1971901464
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-12-08_10:35:46
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded

and in
Version: 4.4.7.2
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL.UTF-8

but not in
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68b


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.1.2 Safari/603.3.8
Comment 1 Telesto 2017-12-09 13:10:25 UTC
This does only happens with pre-build versions - if I'm remembering it correctly - not when building myself (with LODE)

I would might be related to sqlite3 (noticing quite a lot of disk activity)
10176	sqlite3PagerSharedLock	stat64		/Users/demo/Library/Preferences/com.apple.LaunchServices.QuarantineEventsV2-journal
Comment 2 Buovjaga 2017-12-17 16:51:33 UTC
(In reply to Telesto from comment #1)
> This does only happens with pre-build versions - if I'm remembering it
> correctly - not when building myself (with LODE)
> 
> I would might be related to sqlite3 (noticing quite a lot of disk activity)
> 10176	sqlite3PagerSharedLock	stat64	
> /Users/demo/Library/Preferences/com.apple.LaunchServices.QuarantineEventsV2-
> journal

QuarantineEvents sounds like it is some "prison" for suspicious program activity. So the whole thing is due to the operating system doing something (LibO does not use sqlite).
Comment 3 Telesto 2017-12-17 17:02:28 UTC
(In reply to Buovjaga from comment #2)
> (In reply to Telesto from comment #1)
> > This does only happens with pre-build versions - if I'm remembering it
> > correctly - not when building myself (with LODE)
> > 
> > I would might be related to sqlite3 (noticing quite a lot of disk activity)
> > 10176	sqlite3PagerSharedLock	stat64	
> > /Users/demo/Library/Preferences/com.apple.LaunchServices.QuarantineEventsV2-
> > journal
> 
> QuarantineEvents sounds like it is some "prison" for suspicious program
> activity. So the whole thing is due to the operating system doing something
> (LibO does not use sqlite).

There is a reference about SQLite for the NSS library and some special MacOS setting...
https://opengrok.libreoffice.org/xref/core/external/nss/README

But could be a coincidence...
Comment 4 Telesto 2017-12-17 19:04:44 UTC
Created attachment 138495 [details]
Stack without symbols

Notice: libsqlite3.dylib
Comment 5 Telesto 2017-12-17 19:05:58 UTC
Created attachment 138496 [details]
Screenshot
Comment 6 Buovjaga 2017-12-17 19:17:07 UTC
(In reply to Telesto from comment #4)
> Created attachment 138495 [details]
> Stack without symbols
> 
> Notice: libsqlite3.dylib

Explanation found on the web:
Mac OS X Quarantine Event DB

SQLite database that keeps track of files that have the quarantine extended attribute that is given to applications, scripts, and executables downloaded from potentially untrustworthy locations/people. The SQLite database contains URLS, email addresses, email subjects, and other potentially useful information.

/Users/$USERNAME/Library/Preferences/com.apple.LaunchServices.QuarantineEvents
/Users/$USERNAME/Library/Preferences/com.apple.LaunchServices.QuarantineEventsV2
Comment 7 Alex Thurgood 2018-01-04 13:27:30 UTC
Confirming with

Version: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Mac OS X 10.13.2; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 8 Telesto 2018-02-24 17:43:27 UTC
Sigh, I reported this before..

*** This bug has been marked as a duplicate of bug 103892 ***