Bug 114438 - Notebookbar glitches
Summary: Notebookbar glitches
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2017-12-13 12:13 UTC by OfficeUser
Modified: 2017-12-13 19:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2017-12-13 12:13:46 UTC
- Switching between Notebookbar variants often needs to trigger a windows redraw (size change) to remove glitches.

- Unnecessary divider lines are displayed

Screenshot from bug 107224 showing bad divider lines (red highlighted):
http://bugs.documentfoundation.org/attachment.cgi?id=138417



Found with:
Version: 6.1.0.0.alpha0+
Build ID: 8c99d76144b550b17810135418d1c2f12ef8f138
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-26_22:25:0
Comment 1 Yousuf Philips (jay) (retired) 2017-12-13 15:07:25 UTC
(In reply to OfficeUser from comment #0)
> - Switching between Notebookbar variants often needs to trigger a windows
> redraw (size change) to remove glitches.

Please provide clear steps for this, so we can focus on it in this bug.

> - Unnecessary divider lines are displayed
> 
> Screenshot from bug 107224 showing bad divider lines (red highlighted):
> http://bugs.documentfoundation.org/attachment.cgi?id=138417

The divider is part of the contextual group variant of the NB, so please file a new bug for this issue.
Comment 2 OfficeUser 2017-12-13 19:02:04 UTC
I cannot reproduce these glitches anymore after re-starting my computer. So will close it as RESOLVED WORKSFORME. I will re-open it with more details if it starts to appear again.