Bug Hunting Session
Bug 114454 - Cursor jumps to the start of the document upon searching for not existing text
Summary: Cursor jumps to the start of the document upon searching for not existing text
Status: RESOLVED DUPLICATE of bug 101873
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Writer-View-Jumps Find-Toolbar
  Show dependency treegraph
 
Reported: 2017-12-14 09:41 UTC by r.buschbeck
Modified: 2017-12-14 23:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description r.buschbeck 2017-12-14 09:41:09 UTC
Description:
Cursor jumps to the start of the document when the user searches for an expression that does not exist. This is inconvenient in large documents with many pages. Because you first have to find the position again where you were before.

Steps to Reproduce:
1. Open a text document with multiple pages, place the cursor not on first page
2. Press Ctrl+F to search for an expression
3. Type in an expression that does not exist
4. Press Enter multiple times

Actual Results:  
Cursor jumps to the first page

Expected Results:
Cursor stays where it was before


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 5.4.3.2
Build ID: 1:5.4.3~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 raal 2017-12-14 20:12:44 UTC
I can confirm with Version: 6.1.0.0.alpha0+
Build ID: aa28b54ab568fb7160095bb4a2fec338b1398b43
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: x11;

regression, works in 5.0
Comment 2 Thomas Lendo 2017-12-14 23:08:33 UTC
Despite the bad title and description in the other bug, this is a dupe of it. Also bug 101873 was bibisected.

*** This bug has been marked as a duplicate of bug 101873 ***