Download it now!
Bug 114553 - At the Use of Several Columns the Display of the Ruler is Errorneous
Summary: At the Use of Several Columns the Display of the Ruler is Errorneous
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Rulers
  Show dependency treegraph
 
Reported: 2017-12-19 10:25 UTC by Harald Koester
Modified: 2017-12-27 11:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of the two cursor locations (13.83 KB, image/png)
2017-12-26 12:25 UTC, Buovjaga
Details
a 4 coulmn layout, cursor focus in the 4th column (12.82 KB, image/png)
2017-12-26 16:48 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2017-12-19 10:25:48 UTC
In order to reproduce the bug:

[1] Create new text document.
[2] Format Page with two columns: Menu > Format > Page… > Columns > Click icon with two columns and 
[3] change Spacing to 1 cm. Close dialogue with OK. The cursor is positioned at the beginning of the left column.

Have a look at the horizontal ruler now. The writing areas of both columns are displayed with a white background and the areas outside the margins and the spacing are displayed grey. The zero point of the scale is at the left margin of the left column. The scale does not end at the right margin of the left column (8 cm) but is proceeded in the right column (9 cm) and further on beyond the right margin of the right column (17 cm). This is irritating because it seems that the scale belongs to the right column which is not the case. The problem is similar, if the cursor is positioned in the right column. In this case the scale on the left side belongs to the right column.

From my point of view, two solutions are possible:

(a) Each column gets an own scale with a zero point at the left margin of the respective column. 
(b) In the ruler only the writing area of the column in which the cursor is positioned gets a white background. The writing areas for the other columns are greyed.

Personally I prefer solution (a).
Comment 1 Buovjaga 2017-12-26 12:25:30 UTC
Created attachment 138653 [details]
Screenshots of the two cursor locations

Actually the behaviour upon focusing in the right column has changed: in 3.6, the ruler numbering did not change like that. But the behaviour in 3.6 is against the request of this report anyway.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 3272525e6b47af30ea5d92571cd7a6214117d359
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on December 25th 2017
Comment 2 Buovjaga 2017-12-26 12:26:15 UTC
(In reply to Harald Koester from comment #0)
> From my point of view, two solutions are possible:
> 
> (a) Each column gets an own scale with a zero point at the left margin of
> the respective column. 
> (b) In the ruler only the writing area of the column in which the cursor is
> positioned gets a white background. The writing areas for the other columns
> are greyed.
> 
> Personally I prefer solution (a).

Let's ask design team about this.
Comment 3 V Stuart Foote 2017-12-26 16:48:20 UTC
Created attachment 138658 [details]
a 4 coulmn layout, cursor focus in the 4th column

The attached clip shows a 4 column page layout. Cursor focus is in the 4th column (note the tab settings), positive measures extend to page end (e.g. Right) and negative measures extent to page start (e.g. Left) from the 0 point of the current column.

As you move the cursor between columns the 0 point of the ruler adjusts to the active column.

So, we could suppress the ruler to just the column with edit cursor focus--similar to as done for the vertical ruler when adjusting table cell heights.  Or instead set the ruler static for each column--with no negative space, or extent past end position of the column.

But, is a change necessary? The current UI is equally functional--not clear there is anything to be gained with an adjustment.
Comment 4 Heiko Tietze 2017-12-27 11:53:33 UTC
Thumbs relate to the paragraph and not the page settings. So the only solution to the "missing" controls in the second column is to add them there but disable until the cursor focuses a paragraph in this column. Makes no sense to me however and the reason for this ticket is IMHO a misunderstanding that would be better solved by tooltips on the thumbs.