Bug Hunting Session
Bug 114560 - LibreOffice 5.4.3.1 (x64) on Windows 10 - LibO/Writer Crashes when trying to insert Alphabetical Index
Summary: LibreOffice 5.4.3.1 (x64) on Windows 10 - LibO/Writer Crashes when trying to ...
Status: RESOLVED DUPLICATE of bug 113284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-19 15:27 UTC by Chandanathil P. Geevan
Modified: 2017-12-20 18:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot before crashing of LibreOffice (88.12 KB, image/png)
2017-12-19 15:33 UTC, Chandanathil P. Geevan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chandanathil P. Geevan 2017-12-19 15:27:05 UTC
Description:
LibreOffice/Writer crashes when Insert >Table of Contents and Index > Table of Contents .... Bibliography > Type >Alphabetical Index 

ERROR >> Invalid vector <T> subscript 

Fatal Error

After that, the LibreOffice/Writer crashes or becomes unresponsive and the process has to be killed using Windows Task Manager.

Steps to Reproduce:
1. Insert >Table of Contents and Index > 
2. Table of Contents .... Bibliography > 
3. Type >Alphabetical Index 

Actual Results:  
LibreOffice/Writer crashes when Insert >Table of Contents and Index > Table of Contents .... Bibliography > Type >Alphabetical Index 

ERROR >> Invalid vector <T> subscript 

Fatal Error

After that, the LibreOffice/Writer crashes or becomes unresponsive and the process has to be killed using Windows Task Manager.


Expected Results:
Table of Contents, Index or Bibliography
Inserts an index or a table of contents at the current cursor position. To edit an index or table of contents, place the cursor in the index or table of contents, and then choose Insert - Table of Contents and Index - Table of Contents, Index or Bibliography.
To access this command... 
Choose Insert - Table of Contents and Index - Table of Contents, Index or Bibliography
You can also preview the index or table in this dialog.
Depending on the type of index or table that you select, the following tabs are present.
Type
Use this tab to specify and define the type of index that you want to insert. You can also create custom indexes.
Entries (indexes/tables)
Specify the format of the index or table entries. The appearance of this tab changes to reflect the type of index that you selected on the Type tab.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 5.4.3.1 (x64)
Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-GB (en_GB); Calc: group
See Log: 32c8895c6cae21571f364dbb059f419a743ee44d


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.84 Safari/537.36
Comment 1 Chandanathil P. Geevan 2017-12-19 15:33:02 UTC
Created attachment 138524 [details]
screenshot before crashing of LibreOffice
Comment 2 Aron Budea 2017-12-19 15:59:13 UTC
Please update to 5.4.4 once it's released in a few days, the bug is expected to be fixed there.

*** This bug has been marked as a duplicate of bug 113284 ***
Comment 3 Chandanathil P. Geevan 2017-12-20 18:40:07 UTC
Thanks. Installed 5.4.4. The bug is not there.