Bug 114625 - Calc can not print right border of merged cells from LO 6.0
Summary: Calc can not print right border of merged cells from LO 6.0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta2
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 115230 115401 115466 115901 (view as bug list)
Depends on:
Blocks: borderline-regressions
  Show dependency treegraph
 
Reported: 2017-12-21 11:40 UTC by odinatlas
Modified: 2018-02-21 21:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc can not print right border of merged cells (9.26 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-12-21 11:41 UTC, odinatlas
Details
Bibisect log (5.06 KB, text/plain)
2017-12-22 10:42 UTC, Telesto
Details
Example seen n in 6.1+ (18.49 KB, image/jpeg)
2018-02-02 10:07 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description odinatlas 2017-12-21 11:40:49 UTC
Description:
Calc can not print right border of merged cells,
Export pdf will get same result.


Steps to Reproduce:
1.Open Calc and create new spreadsheet.
2.Set outer border and all inner line from A1 to G18.
3.Print ranges define from A1 TO G18.
4.Merge cells F15~G15.
5.Merge cells F16~G16.
6.Merge cells F17~G17.
7.Merge cells F18~G18.
8.G15~G18 right border will not be printed.

Actual Results:  
Calc can not print right border of merged cells

Expected Results:
Calc should print all defined border.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.0.1.0+ (x64)
Build ID: 8d604bbbf8e8906f6e41c7cae808423d2dcae163
CPU threads: 8; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-0, Time: 2017-12-21_04:08:04
Locale: zh-TW (zh_TW); Calc: 


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 odinatlas 2017-12-21 11:41:33 UTC
Created attachment 138565 [details]
Calc can not print right border of merged cells
Comment 2 Timur 2017-12-21 12:21:25 UTC
Repro 6.1+. Looks like regression.
Comment 3 Telesto 2017-12-22 10:42:09 UTC
Created attachment 138592 [details]
Bibisect log

# possible first bad commit: [235e7480e48c60f4e0ec749ffc47eea571d25b6f] source s                                                                             ha:2f16219741aba016677103e4b22738d055c39a91
# possible first bad commit: [dec0cde2fac5069a2886c903fb70c866a0e3c374] source s                                                                             ha:2135e461167dd873fd622e948b88b4194e6854b7
# possible first bad commit: [e33712b2ec213dc3587a6843190f5c7b6568258e] source s                                                                             ha:2813d70f4a7e5522db1056352cd646a585a5c5d0
# possible first bad commit: [390e146005bf27fc785a152c27638b9972bcd385] source s

Adding CC to Armin Le Grand
Comment 4 Xisco Faulí 2018-01-25 15:57:36 UTC
*** Bug 115230 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2018-01-29 11:16:15 UTC
Fixed in

Version: 6.1.0.0.alpha0+
Build ID: 75802ae40ae67737ae9e4f1a38434e0587affff6
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Armin, could you please close this as RESOLVED FIXED ?
Comment 6 S. 2018-01-31 14:47:26 UTC
I am still seeing this bug in the 6.0 RC that openSUSE Tumbleweed is (unfortunately) shipping to its users. I have no idea what version it's really based on, but it says: 
> Version: 6.0.0.2.0+
> Build ID: 00m0(Build:2)
Comment 7 Xisco Faulí 2018-01-31 14:50:32 UTC
(In reply to S. from comment #6)
> I am still seeing this bug in the 6.0 RC that openSUSE Tumbleweed is
> (unfortunately) shipping to its users. I have no idea what version it's
> really based on, but it says: 
> > Version: 6.0.0.2.0+
> > Build ID: 00m0(Build:2)

This will be fixed in 6.0.1.
Comment 8 Xavier Van Wijmeersch 2018-01-31 17:39:48 UTC
its working in

Version: 6.0.1.0.0+
Build ID: 839336e55038ecdda87613c7e61dfd821a97be91
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 9 Timur 2018-02-02 10:07:22 UTC
Created attachment 139524 [details]
Example seen n in 6.1+

I don't see it fixed with libo-master~2018-01-29_05.58.14_LibreOfficeDev_6.1.0.0.alpha0_Win_x86
Moreover, if I zoom in Print Preview, I get lines streched.
Comment 10 Timur 2018-02-02 15:54:44 UTC
*** Bug 115401 has been marked as a duplicate of this bug. ***
Comment 11 Armin Le Grand (CIB) 2018-02-06 18:31:07 UTC
Fixed with changes for tdf#114934, see there
Comment 12 Timur 2018-02-06 18:50:06 UTC
*** Bug 115466 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2018-02-21 21:12:32 UTC
*** Bug 115901 has been marked as a duplicate of this bug. ***