Bug Hunting Session
Bug 114647 - Presentation: multiple animated gifs consumes CPU causing hang
Summary: Presentation: multiple animated gifs consumes CPU causing hang
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Multimonitor Impress-Images
  Show dependency treegraph
 
Reported: 2017-12-22 12:30 UTC by Dwokfur
Modified: 2018-04-15 16:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
to reproduce the problem containing multiple animgifs some sample slides (7.45 MB, application/vnd.oasis.opendocument.presentation)
2017-12-22 12:32 UTC, Dwokfur
Details
openoffice 4.1.5 screen capture, dual display (7.74 MB, video/mp4)
2018-01-17 19:07 UTC, Dwokfur
Details
LibreOffice 6 screen capture, dual display (9.52 MB, video/mp4)
2018-01-17 19:10 UTC, Dwokfur
Details
LibreOffice 6 screen capture, single display (7.13 MB, video/mp4)
2018-01-17 19:11 UTC, Dwokfur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dwokfur 2017-12-22 12:30:52 UTC
Description:
When multiple animated gifs are present on a slide, it causes impress to consume CPU causing a hang in presentation mode. I experience the issue on Windows 7 Pro/Enterprise 64bit, but not on Gentoo compiled from sources.

Steps to Reproduce:
1. Load a presentation with multiple animated gifs on a slide
2. Switch to presentation mode
3. Step to the slide

Actual Results:  
CPU usage goes high, libreoffice becomes unresponsive. Regular users may thing the whole system went down, but switching tasks shows only libreoffice hanged.

Expected Results:
Libreoffice before version 5 and current Openoffice can present such a slide without any problems or hickups.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Dwokfur 2017-12-22 12:32:29 UTC
Created attachment 138593 [details]
to reproduce the problem containing multiple animgifs some sample slides

Sample slides to reproduce the issue on Windows 7 64bit
Comment 2 Dwokfur 2017-12-22 12:41:15 UTC
Upon loading the sample slides enter presentation mode on slide one without animgifs. Proceed to the next slide. The display of the animgifs are sluggish and you can no longer step back-and-forth between slides (at least on an 4 core Core i7). You cannot even leave presentation mode. You must change tasks and kill libre using a task manager of your choice. If the user doesn't the key combination to change tasks, may assume, that the whole OS went down - since presentation mode grabs the focus in full screen.
Comment 3 Dwokfur 2017-12-22 12:42:42 UTC
Disabling OpenGL or hardware acceleration doesn't solve the problem.
Comment 4 Telesto 2017-12-22 16:12:56 UTC
Thanks for the new bug report ;-)

Everything seems smooth to me with:
Version: 6.1.0.0.alpha0+
Build ID: ca1bcb40ea27492c0f3a452c4a318b540a9ff09c
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-21_00:35:39
Locale: nl-NL (nl_NL); Calc: CL

and with
Versie: 6.0.0.1 (x64)
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

with or without OpenGL

Please give 6.0 a try
http://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOffice_6.0.0.1_Win_x64.msi
Comment 5 Jacques Guilleron 2017-12-22 18:27:57 UTC
Hi Dwokfur, Telesto,

Same results as Telesto with
LO 5.0.6.3 Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale : fr-FR (fr_FR)
and 
LO 5.0.0.1 Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Locale : fr-FR (fr_FR)
with and without OpenGL.
under Windows 7.
also with
LO  6.0.0.0.beta1 Build ID: 97471ab4eb4db4c487195658631696bb3238656c
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Since LO 5.3 release, you can experiment a "Resart in Safe Mode..." in Help menu.
This allows you to see if some settings or extensions are involved in your issue by restarting LO temporarily without this features.
Comment 6 Chavdar 2017-12-22 19:23:53 UTC
No system hang experienced.
Laptop specs: i5 2500 ghz, 8 gb of ram and SSDrive
Tested with version:
- 5.4.3.2 (x64)
- 6.0.0.0.beta2 (x64)
Windows 10 64
Locale: bg-BG (bg_BG)
Comment 7 Dwokfur 2017-12-22 21:15:11 UTC
(In reply to Telesto from comment #4)
> Thanks for the new bug report ;-)
> 
> Everything seems smooth to me with:
> Version: 6.1.0.0.alpha0+
> Build ID: ca1bcb40ea27492c0f3a452c4a318b540a9ff09c
> CPU threads: 4; OS: Windows 6.3; UI render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-12-21_00:35:39
> Locale: nl-NL (nl_NL); Calc: CL
> 
> and with
> Versie: 6.0.0.1 (x64)
> Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
> CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: standaard; 
> Locale: nl-NL (nl_NL); Calc: CL
> 
> with or without OpenGL
> 
> Please give 6.0 a try
> http://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOffice_6.0.0.
> 1_Win_x64.msi

Hi Telesto,

I've installed 6.0.0.1 linked. The situation got better in a sense, that I can navigate between slides, and may exit the presentation. But the presentation is still sluggish and the responsiveness is lagging. Toggling OpenGL and hardware acceleration doesn't have any effect on the symptoms. When running the software in safe mode the symptoms stay exactly the same. Openoffice-4.x provides smooth experience in comparison on the same machine. There is a difference, that OOo swaps the two monitors and puts the presentation preview on the other.
I use only the default extensions, which includes Hungarian dictionary.
I can reproduce the problem on multiple Win 7 Enterprise 64bit machines at my workplace (this particular has Q9400 with 8Gb of RAM) and on a laptop that has i7-4900MQ and 32Gb of RAM, running Win 7 Pro 64bit.
Should I capture a video about what is happening or the description is enough?
Comment 8 Telesto 2017-12-25 17:12:03 UTC
> Hi Telesto,
> 
> I've installed 6.0.0.1 linked. The situation got better in a sense, that I
> can navigate between slides, and may exit the presentation. But the
> presentation is still sluggish and the responsiveness is lagging. Toggling
> OpenGL and hardware acceleration doesn't have any effect on the symptoms.
> When running the software in safe mode the symptoms stay exactly the same.
> Openoffice-4.x provides smooth experience in comparison on the same machine.
> There is a difference, that OOo swaps the two monitors and puts the
> presentation preview on the other.
> I use only the default extensions, which includes Hungarian dictionary.
> I can reproduce the problem on multiple Win 7 Enterprise 64bit machines at
> my workplace (this particular has Q9400 with 8Gb of RAM) and on a laptop
> that has i7-4900MQ and 32Gb of RAM, running Win 7 Pro 64bit.
> Should I capture a video about what is happening or the description is
> enough?

Hmmm. It could be a difference in hardware setup? For example multiple monitors (beamer/ secondary screen)? I tested it with a single monitor setup.. A screencast or small video might help too.

Another way would be to find the first version where the problem occurs, and doing a bibisect (https://wiki.documentfoundation.org/QA/Bibisect/Windows)

Older versions are available here:
https://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 9 Dwokfur 2018-01-17 19:07:42 UTC
Created attachment 139161 [details]
openoffice 4.1.5 screen capture, dual display

Smooth motion for all animgifs on adjacent slides. Please note the institution logo at the upper left quadrant of the opening slide: antialiasing along the border of the logo and the annotation beside it.
Comment 10 Dwokfur 2018-01-17 19:10:15 UTC
Created attachment 139162 [details]
LibreOffice 6 screen capture, dual display

The motion of the animgifs is lumpy, adjacent slides are lagging a bit. Please note the institution logo at the upper left quadrant of the opening slide: no antialiasing in edit/plan view.
Comment 11 Dwokfur 2018-01-17 19:11:38 UTC
Created attachment 139163 [details]
LibreOffice 6 screen capture, single display

Motion of the animgifs are just as smooth as for OpenOffice 4.1.5 multiple display.
Comment 12 Telesto 2018-02-27 11:04:11 UTC
(In reply to Dwokfur from comment #10)
> Created attachment 139162 [details]
> LibreOffice 6 screen capture, dual display
> 
> The motion of the animgifs is lumpy, adjacent slides are lagging a bit.
> Please note the institution logo at the upper left quadrant of the opening
> slide: no antialiasing in edit/plan view.

@Buovjaga
Are you able to confirm this?
Comment 13 Dwokfur 2018-02-27 21:15:25 UTC
(In reply to Telesto from comment #12)
> (In reply to Dwokfur from comment #10)
> > Created attachment 139162 [details]
> > LibreOffice 6 screen capture, dual display
> > 
> > The motion of the animgifs is lumpy, adjacent slides are lagging a bit.
> > Please note the institution logo at the upper left quadrant of the opening
> > slide: no antialiasing in edit/plan view.
> 
> @Buovjaga
> Are you able to confirm this?

I've uploaded the sample videos a little bit more than a month ago. It was there in version 5 and I saw it using version 6. Do you want me to check if it can be still observed? I haven't repeated it using the latest version 6. I'm on a business trip right now and currently using my laptop without an additional display. I can retest on Sunday evening or next week. BR: Dw.
Comment 14 Buovjaga 2018-02-28 08:06:51 UTC
(In reply to Dwokfur from comment #13)
> I've uploaded the sample videos a little bit more than a month ago. It was
> there in version 5 and I saw it using version 6. Do you want me to check if
> it can be still observed? I haven't repeated it using the latest version 6.
> I'm on a business trip right now and currently using my laptop without an
> additional display. I can retest on Sunday evening or next week. BR: Dw.

The question was directed at me. I can test it later.
Comment 15 Volga 2018-03-22 16:27:25 UTC
CC: Tomaz Vajngerl
Comment 16 Buovjaga 2018-04-11 16:28:04 UTC
(In reply to Dwokfur from comment #10)
> Created attachment 139162 [details]
> LibreOffice 6 screen capture, dual display
> 
> The motion of the animgifs is lumpy, adjacent slides are lagging a bit.
> Please note the institution logo at the upper left quadrant of the opening
> slide: no antialiasing in edit/plan view.

Tried with dual display on Linux and it was smooth. Not laggy like in the video.
You might want to test with a fresh master build as there have been improvements to bitmap handling: https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current

Version: 6.0.2.1.0+
Build ID: 6.0.2-1
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 17 Dwokfur 2018-04-15 16:18:21 UTC
(In reply to Buovjaga from comment #16)
> (In reply to Dwokfur from comment #10)
> > Created attachment 139162 [details]
> > LibreOffice 6 screen capture, dual display
> > 
> > The motion of the animgifs is lumpy, adjacent slides are lagging a bit.
> > Please note the institution logo at the upper left quadrant of the opening
> > slide: no antialiasing in edit/plan view.
> 
> Tried with dual display on Linux and it was smooth. Not laggy like in the
> video.
> You might want to test with a fresh master build as there have been
> improvements to bitmap handling:
> https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current
> 
> Version: 6.0.2.1.0+
> Build ID: 6.0.2-1
> CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde4; 
> Locale: en-US (en_US.UTF-8); Calc: group

(Under Linux it was OK as well for me.)

I gave a try to the latest development version (Development version 6.1.0.0.alpha0 @ 2018-04-15) and it seems to be fine as well!

Note, that Version 6.0.3.2 (x64) under Windows 7 Professional is still lagging. So 6.1 alpha contains some improvements I'm looking forward to see in the next release!

Best regards:
Dw.
Comment 18 Buovjaga 2018-04-15 16:24:05 UTC
Yep and as those changes are big, they will not be backported to 6.0. Thus, we can close as WFM.