Download it now!
Bug 114655 - [MacOS] Can't open Preferences : LibreOffice 6.0 RC1 crash every time.
Summary: [MacOS] Can't open Preferences : LibreOffice 6.0 RC1 crash every time.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2017-12-22 18:48 UTC by Claude
Modified: 2018-01-23 15:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
After crash message (25.67 KB, image/png)
2017-12-31 20:26 UTC, Claude
Details
Message after crash when in Writer (26.66 KB, image/png)
2017-12-31 20:34 UTC, Claude
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Claude 2017-12-22 18:48:41 UTC
Description:
Like the title says. 

It did not happen with the beta 2 of LibreOffice 6

Steps to Reproduce:
1.Select Preferences
2.Click
3.Crash

Actual Results:  
Crash. 

Expected Results:
No crash!


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xisco Faulí 2017-12-22 21:07:13 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 6a312a4a3d642f0f9769df54c0ec25471c9916bd
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group threaded
Comment 2 Xisco Faulí 2017-12-22 21:07:50 UTC Comment hidden (obsolete)
Comment 3 Claude 2017-12-23 00:09:33 UTC Comment hidden (obsolete)
Comment 4 Claude 2017-12-23 00:10:52 UTC
(In reply to Xisco Faulí from comment #1)
> I can't reproduce it in
> 
> Version: 6.1.0.0.alpha0+
> Build ID: 6a312a4a3d642f0f9769df54c0ec25471c9916bd
> CPU threads: 8; OS: Mac OS X 10.12.6; UI render: default; 
> Locale: en-US (en_ES.UTF-8); Calc: group threaded

Well, not the same version of LibreOffice (6.0 RC1 here), and not the same MacOS version (10.3.2 here.)
Comment 5 Telesto 2017-12-24 15:16:33 UTC
Repro with
Version: 6.0.0.1
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: nl-NL (nl_NL.UTF-8); Calc: group

and also a conformation here:  https://bugs.documentfoundation.org/show_bug.cgi?id=112990#c28

no repro with
Version: 6.1.0.0.alpha0+
Build ID: 184ce84226b49a1b4b693f3bb8cc8569c76d864d
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-12-18_23:53:27
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded
Comment 6 Xisco Faulí 2017-12-25 19:30:55 UTC
I can reproduce it in

Version: 6.0.0.0.beta2+
Build ID: 9c885a05430cf284512e0cb79fc2a996a294aa30
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group threaded

but I can't in

Version: 6.0.0.0.beta2+
Build ID: e027dc4629db2959e2c62b97b463c1846849dbd7
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group threaded
Comment 7 Xisco Faulí 2017-12-25 19:33:21 UTC
Regression introduced in range https://cgit.freedesktop.org/libreoffice/core/log/?h=libreoffice-6-0&qt=range&q=e027dc4629db2959e2c62b97b463c1846849dbd7..9c885a05430cf284512e0cb79fc2a996a294aa30

Adding Cc: to Katarina Behrens

I couldn't bisect it further as the commits in between failed to build.
Comment 8 Claude 2017-12-26 01:12:51 UTC
It's a good thing to know that in futher version the bug doesn't seem to be present.

That said, it is really a critical bug for MacOS users that would like to test the official LibreOffice 6 RC1. 

Not being able to open the Settings/Preferences makes LO not usable, and not only for testing.

Anyways, I hope the RC2 will be OK.
Comment 9 Aron Budea 2017-12-28 21:52:44 UTC
Could someone try getting debug information as described here?
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX
Comment 10 Claude 2017-12-31 00:00:06 UTC
There is no crash report when LibreOffice closes after trying to open the Preferences/Settings. 

It just close the window and you are prompt with a message box asking if you want to recover the last open document.

Opening that last document and try to go the the settings again, you get the same result.
Comment 11 Claude 2017-12-31 20:26:18 UTC
Created attachment 138773 [details]
After crash message

That's the message you get after trying to open the Preferences in LibreOffice 6.0 RC1
Comment 12 Claude 2017-12-31 20:34:58 UTC
Created attachment 138774 [details]
Message after crash when in Writer

And that's the usual message you get after trying to open the Preferences in Writer.

Recover the document works fine. Though, if you try to open the Preferences again, you'll get the same message. 

Trying to Force Quit LibreOffice won't result in a message where you can send infos to Apple about the crash.
Comment 13 Xisco Faulí 2018-01-04 23:25:50 UTC
I can no longer reproduce the crash in

Version: 6.0.0.1.0+
Build ID: db15e9345b96d888070a49b9b7fbe9098435af18
CPU threads: 8; OS: Mac OS X 10.13.2; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group

@Claude, @Telesto, could you please try with the latest daily build fromhttps://dev-builds.libreoffice.org/daily/libreoffice-6-0/MacOSX-x86_64@49-TDF/ ??
Comment 14 Xisco Faulí 2018-01-05 00:02:49 UTC
Actually, I do confirm it's fixed by 29840645e2cb8231040bcbac1b1fe98f494c92c9. I reverted it locally and the crash was present again.
Closing as RESOLVED FIXED.
Thanks to Tor Lillqvist.
Comment 15 Claude 2018-01-05 00:14:02 UTC
Well, If (apparently) nobody knows what cause the crash, who says it won't happen again ?
Comment 16 Claude 2018-01-05 00:22:04 UTC
That said, I can't confirm if it works or not, because MacOS won't let me open the latest daily build, as it is not recognized as "from a known developper".
Comment 17 Claude 2018-01-05 00:29:17 UTC
Forget my last comment. I managed to open it by hitting the ALT key at the same time.

So, yes, I can confirm that this daily build works.