Bug 114677 - Base Form titles incorrect
Summary: Base Form titles incorrect
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.1.0 target:6.0.1
Keywords: bibisected, bisected, regression
: 115580 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-24 01:22 UTC by Stang
Modified: 2018-02-09 17:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
v6 form (25.55 KB, image/png)
2017-12-24 01:23 UTC, Stang
Details
Previous version forms (25.34 KB, image/png)
2017-12-24 01:24 UTC, Stang
Details
bt with debug symbols (4.69 KB, text/plain)
2018-01-25 08:50 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stang 2017-12-24 01:22:36 UTC
Description:
Problem in Beta:

Version: 6.0.0.1
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group


No problem in previous versions.

Title on forms is now "(Embedded document)".


Steps to Reproduce:
1.View ANY Base form in v6.0.0.1
2.
3.

Actual Results:  
Title on forms is now "(Embedded document)".


Expected Results:
Should contain Base name and Form name.


Reproducible: Always


User Profile Reset: No



Additional Info:
Cannot tell what form is being used from what Base file.  Confusing for development & users.

See attached images.


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36
Comment 1 Stang 2017-12-24 01:23:30 UTC
Created attachment 138618 [details]
v6 form
Comment 2 Stang 2017-12-24 01:24:11 UTC
Created attachment 138619 [details]
Previous version forms
Comment 3 robert 2017-12-24 08:59:05 UTC
Could confirm the buggy behavior with 
Version: 6.0.0.0.beta2+
Build ID: d595a081b38bbfda7a64fd1c2680c24880f02025
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-0, Time: 2017-12-09_04:02:02
Locale: de-DE (de_DE.UTF-8); Calc: group threaded

Name of form and name of database isn't shown any more in title of the form.
Comment 4 raal 2017-12-30 16:40:21 UTC
This seems to have begun at the below commit.
Adding Cc: to Szymon Kłos ; Could you possibly take a look at this one?
Thanks

17207732d868995aea444f8323b0b818143cdd21 is the first bad commit
commit 17207732d868995aea444f8323b0b818143cdd21
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Jul 14 19:51:35 2017 +0200

    source sha:68cf76917e342aa5f47deb7e3ef3f7706f8f5a5a

author	Szymon Kłos <szymon.klos@collabora.com>	2017-07-11 17:56:23 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-07-13 13:37:52 +0200
commit	68cf76917e342aa5f47deb7e3ef3f7706f8f5a5a (patch)
tree	af904dcaef425e001d1b7406a4ddb34e8e3a9f84
parent	647382f52351a7586459201203e399956b763527 (diff)
Show document title for embedded documents
Embedded documents had "Untitled" name.
This patch shows "<root document> (Embedded document)"
string in the title bar.
Comment 5 Szymon Kłos 2017-12-31 07:22:07 UTC
I will take a look.
Szymon
Comment 6 Julien Nabet 2018-01-25 08:50:41 UTC
Created attachment 139353 [details]
bt with debug symbols

I attached a bt which shows where title is formed.
Comment 7 Julien Nabet 2018-01-25 08:51:18 UTC
Szymon: any update?
Comment 8 Commit Notification 2018-01-29 08:47:58 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5426a14e39660bde0dece27cf5ec26b9938bd962

tdf#114677 Correct title in Base forms

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-01-29 12:14:16 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=077e0f3b6439dbe9d63aa438b8b076f5d93baf43

tdf#114677 Correct title in Base forms cleanup

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Stang 2018-01-30 17:06:04 UTC
Tested with:

Version: 6.1.0.0.alpha0+
Build ID: e29565272c57c6cd09cb015c2e66bfe8a1f4d7d2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-01-29_23:29:16
Locale: en-US (en_US.UTF-8); Calc: group threaded


Confirmed correction was made and working properly.
Comment 11 Commit Notification 2018-02-07 17:25:44 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=19bfffcf3a89fd2fd070e1a878ac628e93d06cc7&h=libreoffice-6-0

tdf#114677 Correct title in Base forms

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Stang 2018-02-08 16:46:51 UTC
Tested with:

Version: 6.0.1.0.0+
Build ID: d51c01846afb9bea5a39fd48fbb30b9fd02c2870
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-0, Time: 2018-02-08_10:01:18
Locale: en-US (en_US.UTF-8); Calc: group

and Confirmed as working.
Comment 13 Julien Nabet 2018-02-08 17:39:12 UTC
Let's put this one to VERIFIED then.
Comment 14 Julien Nabet 2018-02-09 14:46:50 UTC
*** Bug 115580 has been marked as a duplicate of this bug. ***
Comment 15 tim 2018-02-09 17:27:38 UTC
Thanks. 

Works for me in 6.0.1 (downloaded from The Doc Foundation, no ubuntu ppa version yet available).

Apologies for the duplicate - On this occasion I didn't check first :-(