Download it now!
Bug 114698 - LO documents do not show up in Plasma/KDE history
Summary: LO documents do not show up in Plasma/KDE history
Status: RESOLVED DUPLICATE of bug 70287
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2017-12-26 12:21 UTC by Christian
Modified: 2019-04-03 20:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast demonstrating the problem (3.92 MB, video/mp4)
2017-12-26 12:29 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2017-12-26 12:21:37 UTC
Symptom:
In certain scenarios LibreOffice Documents do not show up in the KDE history (recent documents):

- Creating a new Documents from a Template -> save as...
- Open a LO document from within LO

Please improve the Desktop integration to show up any LO document which shows up in the File > Recent Files menu also in the KDE > history > Recent Documents menu in the K-Menu.
Comment 1 Christian 2017-12-26 12:29:07 UTC
Created attachment 138654 [details]
Screencast demonstrating the problem

h264 in mp4 container - no sound.

Note that the "Verlauf" (== History) is empty after saving new Presentation test4.odp
Comment 2 Buovjaga 2018-01-26 13:57:30 UTC
Confirmed.

The history works by creating .desktop files in ~/.local/share/RecentDocuments
So one would find mydocument.odt.desktop etc. inside that directory.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 19f8a979ff86be39a3938b3d7b25c1431191e708
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on January 25th 2018
Comment 3 QA Administrators 2019-01-27 03:46:28 UTC Comment hidden (obsolete)
Comment 4 Christian 2019-01-27 13:55:23 UTC
Still a problem with Version: 6.1.0.2
Comment 5 Michael Weghorn 2019-04-03 20:27:46 UTC
As mentioned in bug 70287, LibreOffice seems to behave just like other KDE applications in that regard, s. that bug report for more details.

*** This bug has been marked as a duplicate of bug 70287 ***