Download it now!
Bug 114700 - Image Anchor Icon corrupted on HiDPI Displays
Summary: Image Anchor Icon corrupted on HiDPI Displays
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
: 117373 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap HiDPI Icon-Themes
  Show dependency treegraph
 
Reported: 2017-12-26 14:14 UTC by bugzilla2
Modified: 2018-11-29 14:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The broken Image Anchor Icon on HiDPI Display (798 bytes, image/png)
2017-12-26 14:15 UTC, bugzilla2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla2 2017-12-26 14:14:36 UTC
Description:
Image Anchor Icon on Canvas is corrupted on HiDPI Displays (see attached Screenshot).
Happen in Classic Rendering and OpenGL.

(fails on MacBook Pro with Retina Display, OK on Thinkpad T61 with normal DPI).

Steps to Reproduce:
1. Open Writer with blank Document
2. Insert an small Image onto Canvas
3. Look at the Image Anchor Icon on Canvas

Actual Results:  
The Image Anchor Icon is heavily corrupted.

Expected Results:
The Image Anchor Icon should look like on Normal-DPI-Displays.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.97 Safari/537.36 Vivaldi/1.94.1008.40
Comment 1 bugzilla2 2017-12-26 14:15:30 UTC
Created attachment 138657 [details]
The broken Image Anchor Icon on HiDPI Display
Comment 2 Buovjaga 2018-06-07 17:05:39 UTC
*** Bug 117373 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2018-06-07 17:06:14 UTC
Dupe is about resize and rotate handles, but seem similarly broken.
Comment 4 Regina Henschel 2018-10-26 13:15:24 UTC
All handles which are given by file markers.png or cropmarkers.png are affected.
Comment 5 Commit Notification 2018-10-29 21:08:35 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f713caa6f116ee9d6f99e03a688216984cedce44%5E%21

tdf#114700 Single marker files are needed for HiDPI display

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2018-11-29 10:49:48 UTC
A polite ping to Regina Henschel:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 7 Regina Henschel 2018-11-29 14:31:42 UTC
Anchor and marker icons are OK for me on Windows. I cannot test MacBook. All other problems should go into new bug reports.