Bug 114706 - Pasting some paragraphs of text into another paragraph as unformatted text not correct
Summary: Pasting some paragraphs of text into another paragraph as unformatted text no...
Status: RESOLVED DUPLICATE of bug 115088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-12-27 03:03 UTC by Kevin Suo
Modified: 2018-02-09 15:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.91 KB, text/plain)
2017-12-27 17:32 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2017-12-27 03:03:09 UTC
Steps to Reproduce:

1. Create a new Writer document with the following content. 
mmmmmmmmmmm
nnnnnnnnnnnnnnnnn
ooooooooooooooooo

aaa
bbbbb
cccc

2. Copy the abc paragraphs, then paste at the beginning of the m parapraph as unformatted text (Ctrl+Shift+V -> Unformatted Text).

Current Result:
aaammmmmmmmmmm
bbbbb
cccc
nnnnnnnnnnnnnnnnn
ooooooooooooooooo

Expected Result:
aaa
bbbbb
ccccmmmmmmmmmmm
nnnnnnnnnnnnnnnnn
ooooooooooooooooo

3. UNDO.

Current Result:
cccc
nnnnnnnnnnnnnnnnn
ooooooooooooooooo

Expected Result:
mmmmmmmmmmm
nnnnnnnnnnnnnnnnn
ooooooooooooooooo

Version: 6.0.0.1.0+
Build ID:29840645e2cb8231040bcbac1b1fe98f494c92c9
CPU Threads:4; OS:Linux 4.14; UI Render:Default; VCL: gtk2; 
Locale:zh-CN (zh_CN.UTF-8); Calc: group

Version: 5.4.4.2
Build ID:5.4.4.2-1.fc27
CPU Threads:4; 操作系统:Linux 4.14; UI Render:Default; VCL: gtk3; 
Locale:zh-CN (zh_CN.UTF-8); Calc: group
Comment 1 Telesto 2017-12-27 14:23:01 UTC
Confirming. Nice catch, btw
Version: 6.1.0.0.alpha0+
Build ID: ca1bcb40ea27492c0f3a452c4a318b540a9ff09c
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-21_00:35:39
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Telesto 2017-12-27 14:28:39 UTC
Repro with:
Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Windows 6.2; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL

but not with:
Versie: 5.3.5.2 
Build ID: 50d9bf2b0a79cdb85a3814b592608037a682059d
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: group
Comment 3 Telesto 2017-12-27 17:32:31 UTC
Created attachment 138686 [details]
Bibisect log

Bibisected to:

author	Michael Meeks <michael.meeks@collabora.com>	2017-04-24 14:58:54 +0100
committer	Michael Meeks <michael.meeks@collabora.com>	2017-04-25 16:49:41 +0200
commit	e68b6e349c31ac1376e90218013e1e7612f2b522 (patch)
tree	b1c19255d11dc1e99c08b71b4ae12e31412bef7b
parent	dec025d4cb51f252ecd7e981fe36800cf2bedff5 (diff)
Optimize plain-text import.
Cost of managing rsids is very significant >50% of import time, new
Rsids will be generated for changes anyway.
Also avoid un-necessary splitting of paragraphs on new-line.
Comment 4 Telesto 2017-12-27 17:33:26 UTC
Adding CC to: Michael Meeks
Comment 5 Terrence Enger 2017-12-28 01:50:57 UTC
Setting RESOLVED DUPLICATE bug 111349
Comment 6 Telesto 2017-12-28 08:11:18 UTC

*** This bug has been marked as a duplicate of bug 111349 ***
Comment 7 Kevin Suo 2018-02-09 15:31:47 UTC

*** This bug has been marked as a duplicate of bug 115088 ***