Bug 114715 - Fileopen: Table with mixed "allow row to break across pages" incorrectly repeated so DOCX 11 pages instead of 2
Summary: Fileopen: Table with mixed "allow row to break across pages" incorrectly repe...
Status: RESOLVED DUPLICATE of bug 58944
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: lowest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-27 12:36 UTC by MargusL
Modified: 2018-10-09 08:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
file with table displaying bug (18.65 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-12-27 12:38 UTC, MargusL
Details
screenshot, where tables first part is repeated on multiple pages, first 5 pages (601.34 KB, image/jpeg)
2017-12-27 14:48 UTC, MargusL
Details
the first file corrected (34.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-12-27 23:06 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MargusL 2017-12-27 12:36:49 UTC
Description:
Table in MS Office created docx is displayed incorrectly.

Steps to Reproduce:
Added example file "table_is_displayed_incorrectly.docx".


Actual Results:  
First part of table is repeated on multiple pages, so the document is spreaded on 11 pages. MS Office and also TextMaker from Softmaker Software GmbH are displaying correctly.  

Expected Results:
Display table normally.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: et
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 MargusL 2017-12-27 12:38:14 UTC
Created attachment 138683 [details]
file with table displaying bug
Comment 2 tommy27 2017-12-27 13:49:22 UTC
please post a comparative screenshot.
Comment 3 MargusL 2017-12-27 14:48:41 UTC
Created attachment 138684 [details]
screenshot, where tables first part is repeated on multiple pages, first 5 pages
Comment 4 Xisco Faulí 2017-12-27 18:40:06 UTC
Hi MargusL,
Is the screenshot attached done in LibreOffice or MS Word? The problem in this bug is about the table being repeated many times instead of just once?
Regards
Comment 5 Telesto 2017-12-27 19:01:41 UTC
It should probably be a 2 page document, instead off 11 pages

Confirming with:
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: CL

and with:
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 Jacques Guilleron 2017-12-27 23:06:18 UTC
Created attachment 138704 [details]
the first file corrected

Hi all,

Opening this document with Word.
Table properties Line Tab. Options are actuelly :
Allow lines break on several pages
Repeat on top of each page as header line.
These check boxes are blue, but not ticked, and seem interpreted by LO as if this were ticked.
Changing the first setting by tick mark and making the second one empty give the right behavior and a two pages document, on import into LO,
See above attachment.
Comment 7 Timur 2018-01-03 17:52:24 UTC
Bugzilla is "issue based", so a single issue must be pointed at. 
Bugzilla is not "document based", like "this document is displayed incorrectly". 

So what's the issue here? 
Table "Nõupidamisel arutatud teemad" has mixed "allow row to break across pages" (and also "repeat as header row" but I guess it's not the cause) values in different rows. 
LO can't read it properly and shows this table as it, let's guess, has "allow row to break across pages".  
MSO also shows this file as 8 pages if that table set with "allow row to break across pages".  
Again I guess that one would have to look exactly which row makes a problem (or save in MSO with different row values for each row). So, not a simple bug.
Comment 8 Timur 2018-10-09 08:52:26 UTC

*** This bug has been marked as a duplicate of bug 58944 ***