Bug 114726 - Area tabpage: Pattern editor doesn't work, preview not shown
Summary: Area tabpage: Pattern editor doesn't work, preview not shown
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.4.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-12-28 10:42 UTC by Mihkel Tõnnov
Modified: 2018-03-01 08:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
5.4.4: Pattern editor is crossed-out, preview not shown (54.36 KB, image/png)
2017-12-28 10:42 UTC, Mihkel Tõnnov
Details
5.4.3: Pattern editor is functional, preview is shown (52.90 KB, image/png)
2017-12-28 10:43 UTC, Mihkel Tõnnov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2017-12-28 10:42:06 UTC
Created attachment 138707 [details]
5.4.4: Pattern editor is crossed-out, preview not shown

Starting from 5.4.4 rc 1, the pattern editor and pattern preview in Area tab are no longer working. Affects both Writer and Impress (as the Area tab is shared by them). Screenshots attached.

Was still working in 5.4.3 rc 2, broken in 5.4.4 rc 1, still broken in 6.0.0 rc 1.
Comment 1 Mihkel Tõnnov 2017-12-28 10:43:05 UTC
Created attachment 138708 [details]
5.4.3: Pattern editor is functional, preview is shown
Comment 2 Xisco Faulí 2017-12-28 11:14:22 UTC
Regression introduced by:

author	Tor Lillqvist <tml@collabora.com>	2017-11-20 14:23:17 +0200
committer	Tor Lillqvist <tml@collabora.com>	2017-11-20 16:59:02 +0100
commit	66dbd4da3afcadb1393daf9be9cecff71b86509a (patch)
tree	e5a560e6a2bfbd119c0eaaf26d356c065a82ea5a
parent	94c76b6d267ba72177e1144b408b0343d8385c37 (diff)
tdf#113918: Workaround: Load 1bpp indexed PNG as 8bpp indexed Bitmap
The alternative, to fix the X11 disaster area used by the gen, gtk,
and kde4 VCL plugins, seemed more difficult. Somebody else with more
time, feel free to revert and do that instead.

Bisected with: bibisect-linux64-6.0

Adding Cc: to Tor Lillqvist
Comment 3 Mike Kaganski 2017-12-28 11:19:50 UTC
Cannot reproduce with Version: 6.0.0.1 (x64)
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ru-RU (ru_RU); Calc: 

So, Linux only?
Comment 4 Xisco Faulí 2017-12-28 12:18:22 UTC
Right!

I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 864ab0502a4d3506413451e8c545144c6c15d777
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-28_00:54:35
Locale: es-ES (es_ES); Calc: group threaded

but I can in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded