Download it now!
Bug 114729 - Libreoffice draw export as PDF in "selection" mode should create a tight bounding box around the selection
Summary: Libreoffice draw export as PDF in "selection" mode should create a tight boun...
Status: RESOLVED DUPLICATE of bug 40163
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks:
 
Reported: 2017-12-28 12:30 UTC by sergio.callegari
Modified: 2018-01-18 19:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2017-12-28 12:30:16 UTC
Description:
Libreoffice "export as PDF" filter includes a "selection" option to export only the objects that are currently selected.

Unfortunately, even in this case, LibO creates a PDF whose bounding box is as large as the whole page. For this usage case it would be much more useful to create a PDF whose bounding box is tight around the selected objects being exported (or to have an option to enable this behavior).

Steps to Reproduce:
1. Make a small drawing on some standard paper size
2. Select it
3. Export as PDF with export "selection" only

Actual Results:  
See that the PDF page is as large as the paper size

Expected Results:
The PDF bounding box should better fit tightly the selection being exported as PDF.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Buovjaga 2018-01-18 19:00:29 UTC
I can't decide if I should accept this, so let's phone the UX philosophers. It's always a good idea to involve them whenever there is a suggestion "to have an option".
Comment 2 V Stuart Foote 2018-01-18 19:34:40 UTC
Yep, valid, but a long recognized issue, to => DUP

The pdfio filter needs to be tweaked.

*** This bug has been marked as a duplicate of bug 41063 ***
Comment 3 V Stuart Foote 2018-01-18 19:39:27 UTC
Oops, lets mark that with the correct duplicate...

*** This bug has been marked as a duplicate of bug 40163 ***