Download it now!
Bug 114772 - Personalization Fails in 5.4.4.2
Summary: Personalization Fails in 5.4.4.2
Status: RESOLVED DUPLICATE of bug 114731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-30 19:30 UTC by min
Modified: 2018-01-22 10:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Used 6.0.0.1 (33.59 KB, image/png)
2018-01-01 02:59 UTC, Leandro Martín Drudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description min 2017-12-30 19:30:00 UTC
Might be related to Bugs 46014, 101629

Problem: Unable to get personalization to work. It seems to be a proxy problem.

Steps:
1.	On a Win10 machine with Firefox 40, Open Tools\Options\Personalization
2.	Click on Select Theme, LibreOffice,and search, search fails I think because the Internet\Proxy\System is not working.
3.	From Internet\Proxy\System, changing to Manual prevents changing back to System, changing to None, means you can never change to any other setting. The proxy seems to be working in 4.4.7.2, but that version's personalization  does not work with the current firefox.

This is what I tried to find something that worked:

Uninstalled, removed all LibriOffice from the hard drive and registry.
Installed 3.50rc3 from https://downloadarchive.documentfoundation.org/libreoffice/old/, The System setting was now set, but there is no personalization. Note: I had to install Java.
Installed overtop 3.6.04 (no personalization), Installed 4.0.0.1 (personalization fails with newer version of firefox), Installed 5.0.0.1, proxy seems broken, get setup bug warning 1946, uninstalled.
Installed 4.4.7.2, proxy working, personalization nearly works, found bug: https://bugs.documentfoundation.org/show_bug.cgi?id=101629
Installed 5.3.0.1, clean setup (no errors) crashes when pasting in: https://addons.mozilla.org/en-US/firefox/themes
Installed 5.3.0.2, get setup bug warning 1946, proxy broken, uninstalled.
Installed 5.2.7.2, proxy broken, doesn’t find anything in searching.

I was unable to find a work-around,it seems to be the same in 6.0, please let me know if there is a work-around or if both personalization and the system proxy are fixed. Thanks!
Comment 1 Leandro Martín Drudi 2018-01-01 02:58:47 UTC
The same thing happens with 6.0 RC
Comment 2 Leandro Martín Drudi 2018-01-01 02:59:52 UTC
Created attachment 138778 [details]
Used 6.0.0.1

Versión: 6.0.0.1 (x64)
Id. de compilación: d2bec56d7865f05a1003dc88449f2b0fdd85309a
Subproc. CPU: 4; SO: Windows 10.0; Repres. IU: predet.; 
Configuración regional: es-AR (es_AR); Calc: group
Comment 3 Gabor Kelemen 2018-01-05 08:07:12 UTC

*** This bug has been marked as a duplicate of bug 114818 ***
Comment 4 min 2018-01-19 18:59:00 UTC
This still doesn't work in:

Version: 6.0.1.0.0+
Build ID: 10b07347911aee87d13b343072bac01abe0e535a
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:libreoffice-6-0, Time: 2018-01-19_00:50:35
Locale: en-US (en_US); Calc: CL

Granted, it doesn't crash anymore.
But neither does it work.

It is the only reason I would use LibreOffice as most Windows Office apps don't allow personalization, but if you cannot make the feature work, then it should be removed, IMO.
Comment 5 Xisco Faulí 2018-01-22 10:52:19 UTC

*** This bug has been marked as a duplicate of bug 114731 ***