Bug 114803 - 'Scan lines' are showing up in a image when scrolling if the image is anchored As Character
Summary: 'Scan lines' are showing up in a image when scrolling if the image is anchore...
Status: RESOLVED DUPLICATE of bug 114076
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-01-02 13:19 UTC by Telesto
Modified: 2018-02-14 14:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (20.01 KB, application/vnd.oasis.opendocument.text)
2018-01-02 13:20 UTC, Telesto
Details
Screenshot (29.76 KB, image/jpeg)
2018-01-02 13:20 UTC, Telesto
Details
Bibisect log (2.92 KB, text/plain)
2018-01-29 19:42 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-01-02 13:19:55 UTC
Description:
'Scan lines' are showing up in a image when scrolling if the image is anchored As Character

There disappear again after zooming in/out or saving

Steps to Reproduce:
1. Open the attached file 
2. Scroll up and down

Actual Results:  
Lines similar to scan lines (screenshot)

Expected Results:
Shouldn't happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: group threaded

but not in
Version: 6.0.0.0.alpha1+
Build ID: 80af51be1aa85733b9c0b696a93edd8c6520811c
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2018-01-02 13:20:11 UTC
Created attachment 138803 [details]
Example file
Comment 2 Telesto 2018-01-02 13:20:39 UTC
Created attachment 138804 [details]
Screenshot
Comment 3 Buovjaga 2018-01-29 15:24:02 UTC
Repro.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 2d8f17565ebe867210f5769851d91b2e7b612a8f
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on January 27th 2018
Comment 4 Telesto 2018-01-29 19:42:14 UTC
Created attachment 139443 [details]
Bibisect log

Bisected to
uthor	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-11-16 12:54:21 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-11-18 13:07:47 +0100
commit	059469926e359153b9b291790ef2df84fa63fda9 (patch)
tree	0afc7da1aa97c22250823ae43acdfdfd3fdd77b0
parent	d74b26b41bfea3ba7a1834953b2bfe9b7ff0d70f (diff)
RotateFlyFrame3: Corrected Contour when rotated
When rotated, the contour has to be adapted to that state
and also needs to be calculated in untransformed state,
added needed code. Also need to add a ClipRegion set at
the target OutputDevice (e.g. from Contour) to the prepared
GraphicPrimitive. It was sometimes used due to a VCL_Based
PrimitiveRenderer being used, but that is just a coincidence.
Comment 5 Telesto 2018-01-29 19:42:59 UTC
Adding CC to Armin Le Grand
Comment 6 Telesto 2018-02-08 16:12:19 UTC
*** Bug 115533 has been marked as a duplicate of this bug. ***
Comment 7 bordfeldt 2018-02-09 17:43:22 UTC
For me the same in LO 6.0.0.3 on Windows 10 Pro 64bit.
Comment 8 Telesto 2018-02-14 14:37:48 UTC

*** This bug has been marked as a duplicate of bug 114076 ***