Bug Hunting Session
Bug 114810 - FIREBIRD: Tools > SQL doesen't respond to query, causes hang requiring forced kill
Summary: FIREBIRD: Tools > SQL doesen't respond to query, causes hang requiring forced...
Status: RESOLVED DUPLICATE of bug 114702
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Database-Firebird-Default
  Show dependency treegraph
 
Reported: 2018-01-02 18:16 UTC by Robert Großkopf
Modified: 2018-01-04 12:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2018-01-02 18:16:05 UTC
Download the database from here:
https://bugs.documentfoundation.org/attachment.cgi?id=130013

Open the database. Firebird must be enabled as as experimental feature.
Run one query, for example "datediff".
This gives a result.
Now open the query to edit it in SQL-view.
Copy the SQL-code.
Open Tools > SQL.
Mark output of the SQL.
Run the query.

Whole LO hangs, could only be killed.

You could also start directly Tools > SQL in the database and run the following system-code:
SELECT CURRENT_CONNECTION FROM RDB$DATABASE
LO hangs also.

This doesn't happen in LO 5.4.0.3 or LO 5.3.7.2, but happens with LO 5.4.3.2 and newer versions. Haven't installed the versions between 5.4.0.3 and 5.4.3.2 here.

My system: OpenSUSE 42.2 64bit rpm Linux
Comment 1 Alex Thurgood 2018-01-04 09:13:26 UTC
Confirming also on Mac OSX High Sierra 10.13.2 with LO 5432
Comment 2 Alex Thurgood 2018-01-04 09:16:56 UTC
Works correctly in 

Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
Threads CPU : 4; OS : Mac OS X 10.13.2; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

==> regression
Comment 3 Alex Thurgood 2018-01-04 12:28:28 UTC
This appears to workforme in my latest master build (04/01)

Version: 6.1.0.0.alpha0+
Build ID: 5b7ec49f453c3732e2482b26bce4243eb1a10f40
CPU threads: 4; OS: Mac OS X 10.13.2; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group threaded
Comment 4 Lionel Elie Mamane 2018-01-04 12:35:49 UTC

*** This bug has been marked as a duplicate of bug 114702 ***