Bug 114821 - FILEOPEN PPTX: In some files bar chart data labels are incorectly positioned
Summary: FILEOPEN PPTX: In some files bar chart data labels are incorectly positioned
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.1.0 target:6.0.2 target:5.4.6
Keywords: regression
: 75317 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-03 12:58 UTC by Szymon Kłos
Modified: 2018-02-14 09:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file presenting the issue (49.00 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-01-03 12:58 UTC, Szymon Kłos
Details
comparison with MSO (82.13 KB, image/png)
2018-01-03 12:59 UTC, Szymon Kłos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Szymon Kłos 2018-01-03 12:58:46 UTC
Created attachment 138850 [details]
file presenting the issue

1. open attached file
2. "90" and "40" labels are below the chart

expected: "90" and "40" labels should be placed above bars


Version: 6.1.0.0.alpha0+
Build ID: 39a05a41cd9b1f597e80a0e3e117dced07421e39
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: pl-PL (pl_PL); Calc: CL
Comment 1 Szymon Kłos 2018-01-03 12:59:18 UTC
Created attachment 138851 [details]
comparison with MSO
Comment 2 Commit Notification 2018-01-28 13:30:27 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ede9f7ff6f2250fa2c75bc4dc099246a59dcec0

tdf#114821 calculate correct label position

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Timur 2018-01-29 08:50:01 UTC
Labels correctly positioned now. LO 3.4 was fine, looks like regression. 

Still different, could be another bug for direct formatting:
- "90" label is formatted, should be 18, bold, orange color
- "40" label is formatted, should be italic
- second label is "70B", changed to add column name
Comment 4 Szymon Kłos 2018-01-29 09:14:01 UTC
I created another bug for that:
https://bugs.documentfoundation.org/show_bug.cgi?id=115107

(I have patch already, will be merged soon)
Comment 5 Commit Notification 2018-01-29 22:50:24 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=790f9abeb1a1167ad5ab84c5fb855b36669c125b

tdf#114821 import complex data labels in bar chart

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-01-29 22:50:30 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bad41c8fe40e88e416631d61437e6abe5d00131d

tdf#114821 export complex data labels in charts

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-01-30 08:29:32 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=85a7a319bfffb1f709ed504cfadea3bbef077ec1

Revert "tdf#114821 calculate correct label position"

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Szymon Kłos 2018-01-30 08:34:44 UTC
I had to revert my changes due to some problems. I will prepare better fix.
Comment 9 Commit Notification 2018-01-30 19:07:04 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=002b65c5791c8cb31f2790025d7c6fe27041766c

tdf#114821 calculate better label position

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Luke 2018-01-30 22:19:41 UTC
*** Bug 75317 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2018-02-14 09:00:26 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f48053c06cfed8edcbcde08b1c193fd2ad080700&h=libreoffice-6-0

tdf#114821 calculate better label position

It will be available in 6.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-02-14 09:00:37 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=326c9766281e6f80abc042420f1d4be3a27b8aa9&h=libreoffice-5-4

tdf#114821 calculate better label position

It will be available in 5.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.