Bug 114845 - FILESAVE: PPTX Incorrect position of shapes after RT
Summary: FILESAVE: PPTX Incorrect position of shapes after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.2.0 target:6.1.0.1 target:6....
Keywords: bibisected, bisected, filter:pptx, regression
: 118168 (view as bug list)
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2018-01-05 11:15 UTC by Xisco Faulí
Modified: 2018-08-01 10:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison after and before (20.45 KB, image/png)
2018-01-05 11:15 UTC, Xisco Faulí
Details
sample2 (563.50 KB, application/vnd.ms-powerpoint)
2018-01-05 12:20 UTC, Xisco Faulí
Details
sample3 (14.00 KB, application/vnd.ms-powerpoint)
2018-01-05 12:53 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-01-05 11:15:22 UTC
Created attachment 138895 [details]
Comparison after and before

Steps to reproduce:
1. Open attachment 58591 [details] from bug 47434
2. Save it as .PPTX
3. Open the new file

Observed behaviour: the rotated arrow has a different position after the RT.

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-01-05 11:16:59 UTC
Regression introduced by:

author	Szymon Kłos <szymon.klos@collabora.com>	2017-10-24 22:39:08 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-10-26 08:02:13 +0200
commit	9ae1e094d5a8a5b4432c88ebea0ca9fc1c79f602 (patch)
tree	e8ea1f75e72b303b8a6b104021ac771869d26a26
parent	f4df7d2df596bd88e434759a5c108d458a8324b7 (diff)
PPTX export: correct position of rotated groups
* added testcase for tdf#113263

Bisected with: bibisect-linux64-6.0

Adding Cc: to Szymon Kłos
Comment 2 Xisco Faulí 2018-01-05 12:20:35 UTC
Created attachment 138897 [details]
sample2

another document affected by the same problem
Comment 3 Xisco Faulí 2018-01-05 12:51:28 UTC
attachment 50052 [details] from bug 39948 is also affected by the same problem
Comment 4 Xisco Faulí 2018-01-05 12:53:42 UTC
Created attachment 138901 [details]
sample3

Another document affected
Comment 5 Commit Notification 2018-06-25 04:02:02 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=682cf3242272346ad9955cd050a47554930fa8b6

tdf#114845: unit test to prevent a bad fix

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Justin L 2018-06-25 12:11:43 UTC
I didn't notice any problems with the examples provided in comment 2 (Bullet&Numbering-MSOffice2003RT) and comment 4 (mp03_cross)
Comment 7 Justin L 2018-06-25 12:49:59 UTC
*** Bug 118168 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2018-06-27 08:54:10 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee45d881efab230e7682f964d6ad4d00f85b0006

tdf#114845 sd: only shift rotated group items

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-06-28 04:30:57 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dea74f31d2a0062547e279bb934c60731f5e560d&h=libreoffice-6-1

tdf#114845 sd: only shift rotated group items

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-07-10 18:16:05 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3fdff39af3b793f68f9c72d940590948dbb840e2&h=libreoffice-6-0

tdf#114845 sd: only shift rotated group items

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2018-07-11 15:02:49 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 4b345f95ce7cb09011892bf465cfdf3811adaf8e
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Justin Luth, Thanks for fixing this!!!
Comment 12 Commit Notification 2018-07-11 15:20:47 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10272122b2ace68add7d2b0191aa516558f8401f

related tdf#114845 oox: ensure rXShape.is()

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-07-14 20:18:23 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f4f9daeaa1655fea2157dff1eed6f6502bcdb50&h=libreoffice-6-1

related tdf#114845 oox: ensure rXShape.is()

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-07-14 21:57:57 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c262dcbc1bc7d0293c971d01e323cc48e978872a&h=libreoffice-6-0

related tdf#114845 oox: ensure rXShape.is()

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.