Bug Hunting Session
Bug 114850 - Crash in: connectivity::odbc::OConnection::getOdbcFunction(ODBC3SQLFunctionId) const
Summary: Crash in: connectivity::odbc::OConnection::getOdbcFunction(ODBC3SQLFunctionId...
Status: RESOLVED DUPLICATE of bug 114495
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL: crashreport.libreoffice.org/stats/cra...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-05 15:28 UTC by Pieter Wolters
Modified: 2018-01-06 20:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["connectivity::odbc::OConnection::getOdbcFunction(ODBC3SQLFunctionId) const"]


Attachments
ODB file for test database (19.74 KB, application/vnd.oasis.opendocument.database)
2018-01-05 18:09 UTC, Pieter Wolters
Details
SQLITE database (40.00 KB, application/x-sqlite3)
2018-01-05 18:09 UTC, Pieter Wolters
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pieter Wolters 2018-01-05 15:28:09 UTC
This bug was filed from the crash reporting server and is br-c1bbf69a-0566-4a4b-ae87-d5c3c3b6b171.
=========================================

When opening a form with a drop downbox LO crashes, sends a crashreport en restarts. 
* When removing the dropdownboxes the form opens
* When adding a new dropdownbox the form crashes again

This is quite recent behaviour.

See crashreport : https://crashreport.libreoffice.org/stats/crash_details/c1bbf69a-0566-4a4b-ae87-d5c3c3b6b171
Comment 1 Pieter Wolters 2018-01-05 18:09:34 UTC
Created attachment 138905 [details]
ODB file for test database

this file shows a test odb file with a dropdownfield in a form. 

on the start of the form the LO dies. 

sqlite file will be send by also.
Comment 2 Pieter Wolters 2018-01-05 18:09:53 UTC
Created attachment 138906 [details]
SQLITE database
Comment 3 Pieter Wolters 2018-01-05 18:12:09 UTC
version sqlite : 3.8.2 2013-12-06 14:53:30
Comment 4 Xisco Faulí 2018-01-06 20:42:58 UTC

*** This bug has been marked as a duplicate of bug 114495 ***