Bug 114874 - Printing or exporting to PDF results in black squares where image should be
Summary: Printing or exporting to PDF results in black squares where image should be
Status: RESOLVED DUPLICATE of bug 115297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-06 22:47 UTC by brent s.
Modified: 2018-01-31 17:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A quick test document with embedded image - this prints fine (56.84 KB, application/vnd.oasis.opendocument.text)
2018-01-06 22:47 UTC, brent s.
Details
the image file embedded into hptest.odt (45.98 KB, image/jpeg)
2018-01-06 22:48 UTC, brent s.
Details
a document that exhibits the "black block" behavior (19.45 KB, application/vnd.oasis.opendocument.text)
2018-01-06 22:50 UTC, brent s.
Details
the image embedded into keysigning.odt (1.25 KB, image/png)
2018-01-06 22:51 UTC, brent s.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brent s. 2018-01-06 22:47:31 UTC
Created attachment 138928 [details]
A quick test document with embedded image - this prints fine

Hey all! First off, thank you so much for all your hard work. LibreOffice keeps GNU/Linux and other free operating systems as a viable alternative in the business world.

I've recently purchased an HP MFP m281Ffdw ("new" printer) to replace an HP Photosmart 7520 ("old" printer).

Now, I'm noticing some weird things. I'm fairly certain I've managed to rule out the printer and CUPS as being the culprit, as:

- The CUPS test page prints fine
- Text in LibreOffice prints fine
- SOME embedded images print fine
Comment 1 brent s. 2018-01-06 22:48:18 UTC
whoops, hit submit too early.

anyways, when i try to print documents with OTHER images, they print as a large square black block instead.
Comment 2 brent s. 2018-01-06 22:48:57 UTC
Created attachment 138929 [details]
the image file embedded into hptest.odt
Comment 3 brent s. 2018-01-06 22:50:10 UTC
Created attachment 138930 [details]
a document that exhibits the "black block" behavior

this printed fine on "old" printer (and on loffice 5.4.2).
Comment 4 brent s. 2018-01-06 22:51:22 UTC
Created attachment 138931 [details]
the image embedded into keysigning.odt

i should note that when i print this from e.g. eog or other image viewer programs, it prints *fine*, which makes me think it's a libreoffice issue.
Comment 5 Xavier Van Wijmeersch 2018-01-07 15:01:37 UTC
I cannot confirm with

Version: 5.3.1.2
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 8; OS Version: Linux 4.14; UI Render: default; VCL: kde4; Layout Engine: new; Locale: nl-BE (en_US.UTF-8); Calc: group

it exports fine to pdf; but with the newer version of LO there is only a black square [with AOO 4.1.5 its also ok]
Comment 6 j.cottier 2018-01-10 15:00:20 UTC
I have had this today. Documents I regularly print sudden produces solid black squares where the image should be. I guess this has happened since the last update.

This appears to be a regression or similar to Bug 89473. The workaround for that seems to work for this too :-

(workaround: Right-click "Compress Graphic" and "Calculate")

I tried this on all my embedded image and it seems to be fine now. I just need some more black ink!
Comment 7 j.cottier 2018-01-10 16:33:52 UTC
The only snag to that is that the image gets fuzzy. I have found its better if you de-select "Reduce image resolution", then slide the "Jpeg quality" to 99%, then "Calculate new size" and OK. This is more or less original quality then.
Comment 8 Buovjaga 2018-01-31 17:13:36 UTC
Reproduced, but then found a dupe.

*** This bug has been marked as a duplicate of bug 115297 ***
Comment 9 brent s. 2018-01-31 17:21:52 UTC
@Buovjaga -

#115297 explicitly mentions PDF export, this is about printing to a physical printer.

i can export it to PDF fine, the image displays correctly in the PDF. the problem is with actually printing the document, in which case the black image is still present. i'm not so sure this is a dupe.
Comment 10 Buovjaga 2018-01-31 17:28:39 UTC
(In reply to brent s. from comment #9)
> @Buovjaga -
> 
> #115297 explicitly mentions PDF export, this is about printing to a physical
> printer.
> 
> i can export it to PDF fine, the image displays correctly in the PDF. the
> problem is with actually printing the document, in which case the black
> image is still present. i'm not so sure this is a dupe.

Really? But the bug is also in 5.4.4, because the problematic patch was backported and I can reproduce the black square in PDF export with 5.4.4.