Bug 114985 - LO60rc2 macOS: Help window, Settings and other windows open as tabs even when not desired
Summary: LO60rc2 macOS: Help window, Settings and other windows open as tabs even when...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.0
Keywords:
: 103486 106538 115151 (view as bug list)
Depends on:
Blocks: Dialog
  Show dependency treegraph
 
Reported: 2018-01-13 09:23 UTC by Martin Srebotnjak
Modified: 2018-01-28 19:46 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Cropped Settings dialog on macOS (92.51 KB, image/png)
2018-01-13 09:24 UTC, Martin Srebotnjak
Details
Help window on macOS as a tab, cropped/covered (159.80 KB, image/png)
2018-01-13 09:29 UTC, Martin Srebotnjak
Details
Insert Characters window, tabbed and cropped, useless (116.14 KB, image/png)
2018-01-13 09:38 UTC, Martin Srebotnjak
Details
Insert Table window on macOS, tabbed, stretched and cropped, useless (52.36 KB, image/png)
2018-01-13 09:39 UTC, Martin Srebotnjak
Details
Patch (540 bytes, text/plain)
2018-01-17 15:28 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2018-01-13 09:23:54 UTC
Description:
Opening LO60 on macOS and then opening the Settings dialog, the dialog opens as a tab (why?) and it is top cropped, as seen on the attached screenshot.

Steps to Reproduce:
1. Open LO6 on macOS
2. Open Settings dialog
3.

Actual Results:  
Cropped Settings dialog in tabs.

Expected Results:
Non-cropped, non-tabbed Settings dialog.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Martin Srebotnjak 2018-01-13 09:24:50 UTC
Created attachment 139072 [details]
Cropped Settings dialog on macOS

Cropped Settings dialog, displayed by default as a tab - with Slovenian UI.
Comment 2 Martin Srebotnjak 2018-01-13 09:26:45 UTC
Actually, same happens with the Help dialog, it opens as a tab and its top part is cropped, thus the field for selecting the help content (module) and icons are covered and can hardly be used.
Really a big problem, maybe a stopper?
Comment 3 Martin Srebotnjak 2018-01-13 09:29:32 UTC
Created attachment 139073 [details]
Help window on macOS as a tab, cropped/covered

Help window on macOS is tabbed (why at all?, I do not want to cover my current document I edit with the help window, I want the help window to be beside my main window for editing) and the top row is covered making the help window barely useful.
Comment 4 Martin Srebotnjak 2018-01-13 09:34:43 UTC
Why would the user want the Help window to open as a tab thus covering the main editing window?
One wants to open help to read what to do in the main window so you probably want the help window to hover at the side, same goes for the Settings window.
Comment 5 Martin Srebotnjak 2018-01-13 09:38:07 UTC
Ok, this is a serious issue, also windows like "Insert Table" and "Insert Character" also open in tabs (and of course crops the top line with settings, strings etc.), which makes work LO pretty strange on macOS.
Comment 6 Martin Srebotnjak 2018-01-13 09:38:50 UTC
Created attachment 139074 [details]
Insert Characters window, tabbed and cropped, useless
Comment 7 Martin Srebotnjak 2018-01-13 09:39:32 UTC
Created attachment 139075 [details]
Insert Table window on macOS, tabbed, stretched and cropped, useless
Comment 8 Tor Lillqvist 2018-01-13 10:20:55 UTC
Can anybody else reproduce this? I can't. Are you sure you haven't installed some "useful" 3rd-party extension to macOS on your machine that causes the windows to behave like this?
Comment 9 Martin Srebotnjak 2018-01-13 10:34:08 UTC
No, Tor, give me some credit, I know I have to test this without such additions.

The only installed extensions are dictionaries and linear solver, as included with the official LO install.
It also happens with the "safe mode" and extensions disabled.
Comment 10 Martin Srebotnjak 2018-01-13 10:34:52 UTC
I can drag such a tabbed window out of the main window and then it remains as a detached window. Which is probably expected behaviour for tabbed windows.
Comment 11 Martin Srebotnjak 2018-01-13 10:45:07 UTC
It seems to be a Sierra (and newer OS versions) system option to open all program windows in tabs, not separate windows.

I did not set that setting myself in the OS, I never touched it, and it is set to Always (System Preferences - Dock - Prefer tabs when opening documents). Probably new OS versions or some programs set it to that.

I now set this to "Manually" and it seems to work fine.

I guess with this option present in macOS LO should override such a system setting when it is not a document window but a setting/help window and should force opening it in a separated window.

Also, the windows that do open in such a tabbed way should in their design respect this option (probably it is a flag of some kind that needs to be in the code) and not have its upper part cropped.
Comment 12 Tor Lillqvist 2018-01-13 23:00:48 UTC
Oh, so there is a system setting that causes this. Yeah, when I tried that, I can reproduce it. Still, I wouldn't object resolving this as NOTABUG.
Comment 13 Martin Srebotnjak 2018-01-13 23:26:19 UTC Comment hidden (abusive)
Comment 14 Telesto 2018-01-14 11:16:16 UTC
By default, documents open in tabs only when an app is full screen based on https://support.apple.com/kb/PH25244?locale=en_US 

The clue of this opinion is to have a single setting for all possible apps apps to prefer tabs with opening documents new or old, or creating new documents. 

The behavior of LibreOffice will make it useless, in general. MacOS assumes support for tabs, unless the setting is otherwise. It should - ideally - be disabled in app. This shouldn't be to hard; probably only one line of code

https://stackoverflow.com/questions/39399553/how-do-i-disable-the-show-tab-bar-menu-option-in-sierra-apps
Comment 15 Tor Lillqvist 2018-01-15 13:15:46 UTC
If this is related to the desktop "full screen app" concept, I can only once again repeat my opinion that we should remove from LibreOffice all our broken attempts to support that. It t is silly to have both that and LibreOffice's own "full screen" concept. (They are not in sync at all.) If we really want to have a proper (macOS native) "full screen" thing on macOS, it should completely replace the built-in cross-platform "full screen" thing.
Comment 16 Telesto 2018-01-15 13:32:52 UTC
(In reply to Tor Lillqvist from comment #15)
> If this is related to the desktop "full screen app" concept, I can only once
> again repeat my opinion that we should remove from LibreOffice all our
> broken attempts to support that. It t is silly to have both that and
> LibreOffice's own "full screen" concept. (They are not in sync at all.) If
> we really want to have a proper (macOS native) "full screen" thing on macOS,
> it should completely replace the built-in cross-platform "full screen" thing.

This will also happen in normal screen mode with "Prefer tabs when opening documents" set to Always. It's a problem in full screen mode too, but that isn't relevant here.
Comment 17 Tor Lillqvist 2018-01-15 15:44:06 UTC
Telesto's link in comment #14 should make it easy to fix this misfeature. Possibly one could even fix it so that for document windows, the "tabbing" behaviour still happens when desired by the user in the system preferences, but not for dialogs.
Comment 18 Telesto 2018-01-17 15:28:45 UTC
Created attachment 139152 [details]
Patch

A non-developer proposal for a patch based on https://codereview.chromium.org/2325313002/
Working as expect, as far I can tell..
Comment 19 Martin Srebotnjak 2018-01-17 21:41:40 UTC
It would be great to test this in time to get it into RC3 (=release).
Comment 20 Tor Lillqvist 2018-01-22 12:48:02 UTC
Thanks, that indeed seems to work. Telesto, do you want to be credited for the patch? What is your real name?
Comment 21 Tor Lillqvist 2018-01-22 13:52:39 UTC
https://gerrit.libreoffice.org/#/c/48330/
Comment 22 Xisco Faulí 2018-01-22 15:15:55 UTC
*** Bug 115151 has been marked as a duplicate of this bug. ***
Comment 23 Commit Notification 2018-01-23 08:19:40 UTC
Telesto committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce88f2a7374bb8c53d57e8263e0701db19d62f30

tdf#114985: Tell NSWindow to never use automatic window tabbing

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2018-01-23 13:19:04 UTC
Telesto committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5163257c0d194f534887d92c6c9658640eeef3e1&h=libreoffice-6-0

tdf#114985: Tell NSWindow to never use automatic window tabbing

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2018-01-24 15:52:57 UTC
Telesto committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e406259319054024f032c0d5b7468136c13b3733&h=libreoffice-6-0-0

tdf#114985: Tell NSWindow to never use automatic window tabbing

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Maxim Monastirsky 2018-01-28 14:19:04 UTC
*** Bug 103486 has been marked as a duplicate of this bug. ***
Comment 27 Maxim Monastirsky 2018-01-28 14:19:49 UTC
*** Bug 106538 has been marked as a duplicate of this bug. ***
Comment 28 Martin Srebotnjak 2018-01-28 19:46:49 UTC
I can confirm that this was neatly fixed and is not present in 6.0RC3 anymore.
Thanks, Telesto!