Bug 115057 - Color picker widget border missing when opened in dialog
Summary: Color picker widget border missing when opened in dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:6.1.0 target:6.0.1
Keywords: regression
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2018-01-16 23:33 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-01-27 20:01 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2018-01-16 23:33:41 UTC
Steps:
1. open writer
2. open character dialog
3. open font color control in font effects tab
4. border around opened widget gone

regression as the border is there in 5.4.

Version: 6.1.0.0.alpha0+
Build ID: acb43c0b8efbfb841e7b40603d75a8432eb21f21
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-01-09_01:20:44
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 1 Maxim Monastirsky 2018-01-17 00:15:53 UTC
Obviously related to my work on Bug 106762. I see now where the problem is, taking.
Comment 2 Commit Notification 2018-01-18 20:50:17 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=829b0564959411d0cc64169fe69153a714050c0d

tdf#115057 Never use ImplPopupFloatWin for anything except ToolBox

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2018-01-27 20:01:25 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a658ed6be2072b54fa0ec4759f24c00639145a06&h=libreoffice-6-0

tdf#115057 Never use ImplPopupFloatWin for anything except ToolBox

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.