Bug 115084 - Incorrect shortcut key behavior in Options
Summary: Incorrect shortcut key behavior in Options
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Katarina Behrens (CIB)
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords: accessibility
: 116016 (view as bug list)
Depends on:
Blocks: Digital-Signatures Options-Dialog-UserData
  Show dependency treegraph
 
Reported: 2018-01-18 09:56 UTC by baffclan
Modified: 2018-03-09 11:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2018-01-18 09:56:50 UTC
Description:
Incorrect shortcut key behavior in Options


Steps to Reproduce:
1. Start LibO-Dev
2. Open a Options
   Menu - Tools - Options...
3. Appear Options
4. Clock/Open a LibreOffieDev - User Data
5. Type [Alt]+[O]



Actual Results:  
"OpenPGP encryption key" box has Focused


Expected Results:
"OpenPGP signing key" box has Focused



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+ (x64)
Build ID: facfc2951ea9f4745edd4a6fb1cf97697f33f40a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2018-01-14_00:42:04
Locale: ja-JP (ja_JP); Calc: group threaded



User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Aron Budea 2018-01-22 04:17:45 UTC
Confirmed with LO 6.0.0.2 / Windows 7.
Comment 2 Katarina Behrens (CIB) 2018-03-01 21:17:13 UTC
*** Bug 116016 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2018-03-07 09:01:17 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74a027f927289911b3b712c1ea0f350cf631b0ae

tdf#115084: fix sloppy mnemonic ID

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2018-03-09 04:25:50 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7b8516ac7fc0c4d91b1439626a334fd0778680c7&h=libreoffice-6-0

tdf#115084: fix sloppy mnemonic ID

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 baffclan 2018-03-09 11:06:28 UTC
Cannot reproduced with master/Win-x86_64@42

Version: 6.1.0.0.alpha0+ (x64)
Build ID: daf17846789cf09d1861f1e6f03851d2e12cffc8
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-09_07:44:42
Locale: ja-JP (ja_JP); Calc: group

Thanks for fixing this.

-> VERIFIED