Bug 115142 - When an image is bigger than the slide impress shrinks it to the size of the slide
Summary: When an image is bigger than the slide impress shrinks it to the size of the ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.4.1 rc
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.1.0 target:5.4.7 target:6.0....
Keywords: bibisected, bisected, regression
: 115652 115667 116023 116193 116196 116220 (view as bug list)
Depends on:
Blocks: Impress-Images
  Show dependency treegraph
 
Reported: 2018-01-22 07:30 UTC by Michael Demetriou
Modified: 2018-03-27 12:48 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Single slide showcase of the bug. Just press F5 (5.03 MB, application/vnd.oasis.opendocument.presentation)
2018-01-22 07:31 UTC, Michael Demetriou
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Demetriou 2018-01-22 07:30:24 UTC
Description:
Images larger than the slide are being resized to fit the slide when presenting. This breaks compatibility with MS Office and older Impress presentations.

Steps to Reproduce:
1. Add an image
2. Resize it so that parts stick out of the frame
3. Press F5.

Actual Results:  
the image is now as big as the slide.

Expected Results:
the image should be cropped out of screen


Reproducible: Always


User Profile Reset: No



Additional Info:
I have tested it on a Mac and a Linux machine


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Michael Demetriou 2018-01-22 07:31:19 UTC
Created attachment 139249 [details]
Single slide showcase of the bug. Just press F5
Comment 2 Regina Henschel 2018-01-22 11:00:57 UTC
It was OK in Version: 5.4.3.2 (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL

I see the error in Version: 5.4.4.1 (x64)
Build ID: da790616461e15a10c95a80eb8ef8ee7b726c114
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL
and still in Version: 6.1.0.0.alpha0+ (x64)
Build-ID: facfc2951ea9f4745edd4a6fb1cf97697f33f40a
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2018-01-14_00:42:04
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 3 Chavdar 2018-01-22 19:48:11 UTC
Confirmed

Version: 5.4.4.2 (x64)
Build ID: 2524958677847fb3bb44820e40380acbe820f960
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: bg-BG (bg_BG); Calc: group

Version: 6.1.0.0.alpha0+
Build ID: d28e10b095b4ee0986fbe86170928bf077da04b9
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2018-01-13_22:59:50
Locale: bg-BG (bg_BG); Calc: group threaded
Comment 4 Xisco Faulí 2018-01-23 10:03:43 UTC
Regression introduced by:

author	Michael Stahl <mstahl@redhat.com>	2017-11-10 23:28:19 +0100
committer	Michael Stahl <mstahl@redhat.com>	2017-11-10 23:53:15 +0100
commit	99e373cd4c78084ded349f3e3de7b0504af2dd90 (patch)
tree	0c1ff8718814ac92ee6f2f766d0c66bf94f32343
parent	3c18e816c23f1e49a44b12cf7aee10c47af7e2ec (diff)
slideshow: clip shapes in secondary screen window
When using the presenter console, the secondary screen has
a small view of the current slide.

Currently nothing clips the shapes that are on the slide,
so they may be rendered outside the slide rectangle,
because there's a single VCL-canvas and OutPutDevice that covers
the entire screen.

Set up some brute force clipping in DrawShape::getViewRenderArgs().

Bisected with: bibisect-linux64-6.0

Adding Cc: to Michael Stahl
Comment 5 elfriedo_20002000 2018-02-02 15:57:19 UTC
I went through the LibreOffice versions in https://downloadarchive.documentfoundation.org/libreoffice/old/ and found that 5.4.4.1 was the earliest affected (Mac x86-64).
Comment 6 Ilya Zverev 2018-03-02 21:28:19 UTC
*** Bug 115667 has been marked as a duplicate of this bug. ***
Comment 7 Ilya Zverev 2018-03-02 21:29:11 UTC
*** Bug 116023 has been marked as a duplicate of this bug. ***
Comment 8 Ilya Zverev 2018-03-02 21:33:08 UTC
I should add that when exporting to PDF, images are properly clipped. So while this bug makes LibreOffice unusable for presentations with large images, you can still export to a PDF and present from it.
Comment 9 Ilya Zverev 2018-03-02 21:55:37 UTC
Also this affects text boxes: for example, make a text box much wider than the slide, paste some text with long lines there, and press F5. It would be shrunk to the slide width.
Comment 10 Ilya Zverev 2018-03-06 11:26:53 UTC
*** Bug 116220 has been marked as a duplicate of this bug. ***
Comment 11 Michael Stahl (CIB) 2018-03-07 10:08:46 UTC
it turns out the commit #4 does scaling and not clipping so it's nonsense and should be reverted; i'll try to find a different fix for the clipping problem.
Comment 12 Commit Notification 2018-03-07 12:12:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0408a590311c837d5f0ab1abfb72a564a266ddac

tdf#115142 Revert "slideshow: clip shapes in secondary screen window"

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-03-07 12:12:32 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d710cf7dda27e78f237211fd92418be4dd1c551

VCL canvas: fix clipping of gradients (related: tdf#115142)

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Michael Stahl (CIB) 2018-03-07 12:15:08 UTC
sorry about that, it's fixed on master
Comment 15 Michael Stahl (CIB) 2018-03-07 12:15:36 UTC
*** Bug 116196 has been marked as a duplicate of this bug. ***
Comment 16 Michael Stahl (CIB) 2018-03-07 12:29:25 UTC
*** Bug 115652 has been marked as a duplicate of this bug. ***
Comment 17 Ilya Zverev 2018-03-07 13:48:39 UTC
Awesome, thanks for fixing this Michael!
Comment 18 Ilya Zverev 2018-03-07 13:51:02 UTC
By the way, what is the process for it to be cherry-picked into 6.0.x branch? There are six related issues filed already, and the bug is quite prominent.
Comment 19 Xisco Faulí 2018-03-07 14:17:28 UTC
(In reply to Ilya Zverev from comment #18)
> By the way, what is the process for it to be cherry-picked into 6.0.x
> branch? There are six related issues filed already, and the bug is quite
> prominent.

It can be done from gerrit if there're not conflicts. The patch is awaiting for review in 6-0 and 5-4 branches: https://gerrit.libreoffice.org/#/q/tdf%2523115142+status:open
Comment 20 Commit Notification 2018-03-07 21:21:21 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c59c43ecfb7b858557c82bb3733ba72f0f23d3df&h=libreoffice-5-4

VCL canvas: fix clipping of gradients (related: tdf#115142)

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2018-03-07 21:21:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e89b8a1b5c2312b8d5f96dadb98bdab6b9e44528&h=libreoffice-6-0

VCL canvas: fix clipping of gradients (related: tdf#115142)

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2018-03-07 21:22:55 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c66530237998641411f30be8ee1bd0ef86106404&h=libreoffice-6-0

tdf#115142 Revert "slideshow: clip shapes in secondary screen window"

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2018-03-07 21:23:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cbc114a8d86d94743562c2eec7a8eef23d2d2297&h=libreoffice-5-4

tdf#115142 Revert "slideshow: clip shapes in secondary screen window"

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2018-03-08 10:53:51 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e8ed3dfc35975b9e57da7803168f3e2a117a4004

VCL canvas: fix another clipping mistake (related: tdf#115142)

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2018-03-08 13:44:29 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a1b3ae95e35fe0669bcc9df020fa606e6a3cca75&h=libreoffice-6-0

VCL canvas: fix another clipping mistake (related: tdf#115142)

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2018-03-08 13:45:48 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5acef0c01a38cb9217bef5b38ba521c23c304e0f&h=libreoffice-5-4

VCL canvas: fix another clipping mistake (related: tdf#115142)

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2018-03-13 23:28:25 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b327393da7fb0fb2e28a3571502a95869b225744&h=libreoffice-5-4-6

VCL canvas: fix another clipping mistake (related: tdf#115142)

It will be available in 5.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2018-03-14 12:20:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f7fa0cc2ff64b81d96b160584a534f2f91e8a15&h=libreoffice-5-4-6

VCL canvas: fix clipping of gradients (related: tdf#115142)

It will be available in 5.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2018-03-14 12:20:54 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=da85e5327844ec525e08fbb012389b8e90744bcf&h=libreoffice-5-4-6

tdf#115142 Revert "slideshow: clip shapes in secondary screen window"

It will be available in 5.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Ilya Zverev 2018-03-27 12:31:01 UTC
Tested it in 5.4.6, the bug is fixed. Thank you!
Waiting for 6.0.3.
Comment 31 Ilya Zverev 2018-03-27 12:48:42 UTC
*** Bug 116193 has been marked as a duplicate of this bug. ***