Download it now!
Bug 115149 - Conditional Formatting gets messed up when pasting new rows
Summary: Conditional Formatting gets messed up when pasting new rows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-01-22 12:39 UTC by jonas.dorel
Modified: 2018-03-25 16:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonas.dorel 2018-01-22 12:39:56 UTC
Description:
When inserting new rows with conditionnal formatting A between rows using the same conditionnal formatting A, it breaks the interval in the conditionnal formatting manager. For exemple, if you copy it in row 7, A5:A10 becomes A7 and A8:A10,A5:A6.

Steps to Reproduce:
1.Apply a conditional formatting to an interval
2.Copy a cell from that interval
3.Paste this cell in a the interval

Actual Results:  
Interval gets cut

Expected Results:
Interval should remain the same


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 5.4.2.2 (x64)
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Buovjaga 2018-02-12 17:45:30 UTC
Jonas: do you think this is the same as bug 109280?
Comment 2 jonas.dorel 2018-02-13 11:20:58 UTC
It is, but I don't have to restart Calc to see it happen
Comment 3 Buovjaga 2018-02-13 11:26:46 UTC
(In reply to jonas.dorel from comment #2)
> It is, but I don't have to restart Calc to see it happen

Hmm, yes, maybe this is different, so I will not close as duplicate.
Comment 4 Xavier Van Wijmeersch 2018-02-13 12:50:59 UTC
with

Version: 6.1.0.0.alpha0+
Build ID: c6a23023150c164a19236139fa413d43006ce21c
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group

inserting a row in a cf everything goes well but inserting a column/left then the cf change in a weird result

and with

Version: 5.4.6.0.0+
Build ID: 01f19aba638860db54ca9a60e30ce6f21ee0ea5a
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group

I can not reproduce the problem

don,t use copy/past because its will make change's to the cf
insert row or column; copy and use past special as a workaround

regards
Comment 5 Xisco Faulí 2018-03-19 15:56:45 UTC
(In reply to Xavier Van Wijmeersch from comment #4)
> with
> 
> Version: 6.1.0.0.alpha0+
> Build ID: c6a23023150c164a19236139fa413d43006ce21c
> CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
> Locale: nl-BE (en_US.UTF-8); Calc: group
> 
> inserting a row in a cf everything goes well but inserting a column/left
> then the cf change in a weird result
> 

Hi Xavier,
is this issue you're describing still reproducible?
Should it be reported in a new bug?
Comment 6 Xavier Van Wijmeersch 2018-03-20 15:41:20 UTC
@Xisso

the issue, comment4, I can not reproduce it anymore.
I think the problem is solved

Version: 6.1.0.0.alpha0+
Build ID: 43446fa03995fb5d1379fc0afbeec36c9dedfde2
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 7 Buovjaga 2018-03-21 19:45:31 UTC
Jonas: as there is a suspicion that the bug is gone, could you test with a daily build? https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 8 jonas.dorel 2018-03-25 14:02:51 UTC
It seems that I cannot reproduce it in version 6.0.1