Bug 115169 - Calc: Rotated Cells not shown rotated when using Print/PDF/PrintPreview
Summary: Calc: Rotated Cells not shown rotated when using Print/PDF/PrintPreview
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Armin Le Grand (CIB)
URL:
Whiteboard:
Keywords:
: 114920 (view as bug list)
Depends on:
Blocks: borderline-regressions
  Show dependency treegraph
 
Reported: 2018-01-23 13:38 UTC by Armin Le Grand (CIB)
Modified: 2018-02-06 18:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Armin Le Grand (CIB) 2018-01-23 13:38:45 UTC
Description:
Using 'text orientation' to rotate a cell in calc is not represented in outputs except EditView

Steps to Reproduce:
1. new calc
2. select one cell, set border good visible (red, 4")
3. rotate (use sidebar 'text orientation', e.g. 45 deg)
4. PrintPreview/PDFExport/Print -> rotation not used


Actual Results:  
Cell shown without set rotation

Expected Results:
Cell shown with set rotation


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xisco Faulí 2018-01-23 14:27:27 UTC
Moving to ASSIGNED. Thanks Armin for working on this
Comment 2 Xisco Faulí 2018-01-25 10:08:01 UTC
*** Bug 114920 has been marked as a duplicate of this bug. ***
Comment 3 Armin Le Grand (CIB) 2018-02-06 18:31:17 UTC
Fixed with changes for tdf#114934, see there