Bug Hunting Session
Bug 115186 - VIEWING: Font dropdown menu too small and recent fonts not saved
Summary: VIEWING: Font dropdown menu too small and recent fonts not saved
Status: RESOLVED DUPLICATE of bug 91130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-List
  Show dependency treegraph
 
Reported: 2018-01-24 03:24 UTC by Flora Canou
Modified: 2018-02-13 10:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Flora Canou 2018-01-24 03:24:17 UTC
Description:
The dropdown menu of font shows only 12 fonts simultaneously, too little for users like me who install hundreds (if not thousands) of fonts on system. I also recommend expanding it horizontally so that I could type OpenType features more easily. In addition, it would be better if the recently used fonts could be saved after reopening the program and maybe adding the function of favorite fonts like the special characters dialog you team just made brilliantly. 

Steps to Reproduce:
1. Start Writer or Calcand click the dropdown menu of font

Actual Results:  
The dropdown menu of font shows only 12 fonts simultaneously. 
Recently used fonts not saved. 

Expected Results:
24 should be much better, or a chance to customize it. 
Recently used fonts should be saved. 


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Heiko Tietze 2018-02-13 10:00:50 UTC
The font selection is provided via dropdown controls today that shouldn't expand beyond 8 items. Actually it's a combobox and you can type to find what you are looking for (not an ideal solution). 

Had a talk recently about this topic https://de.slideshare.net/HeikoTietze/improvements-to-font-handling-in-libreoffice You are welcome to join the discussion.

Closing your ticket for a coherent discussion as dup of bug 101748 (customization), bug 90161 (highlighting), and bug 91130 (smaller list, grid control in comment 12).

*** This bug has been marked as a duplicate of bug 91130 ***