Download it now!
Bug 115231 - FILESAVE: ODT: Signature is not displayed after RT
Summary: FILESAVE: ODT: Signature is not displayed after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:odt, regression
Depends on:
Blocks:
 
Reported: 2018-01-25 16:00 UTC by Xisco Faulí
Modified: 2018-03-28 14:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (11.89 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-01-25 16:00 UTC, Xisco Faulí
Details
How it looks after the RT (35.40 KB, image/png)
2018-01-25 16:01 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-01-25 16:00:53 UTC
Created attachment 139365 [details]
sample file

Steps to reproduce:
1. Open attached document
2. Save it as .ODT ( not reproduced if saved to .DOCX )
3. Open the new document

Observed behaviour: not found image is displayed instead of the signature. See attached image

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 5cb225b0b3dbb55fd44899b1fb16bdcfeb866849
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-01-25 16:01:13 UTC
Created attachment 139366 [details]
How it looks after the RT
Comment 2 Xisco Faulí 2018-01-25 16:02:31 UTC
Regression introduced by:

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-12-11 16:13:07 +0100
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-12-12 11:18:33 +0100
commit	f64a78b49bffdbc614e1fcdc8ff906edd895b65e (patch)
tree	28769a65e5400ae47c56b4b3a69b475fd3481f78
parent	ea0e5ac64820976a2ae124e47156dd94407bf874 (diff)
Related tdf#83877 Add signatureline element to draw:frame, not draw:image
Because a frame can have multiple (fallback) images, so this would have been
added only to the first one.

Bisected with: bibisect-linux64-6.1

Adding Cc: to Samuel Mehrbrodt
Comment 3 Samuel Mehrbrodt (CIB) 2018-01-25 19:42:26 UTC
The import is not yet implemented ;)
Bug 83877 is still in progress...

But note that this only affects current master, not any released version.
Comment 4 Xisco Faulí 2018-01-26 10:37:20 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> The import is not yet implemented ;)
> Bug 83877 is still in progress...
> 
> But note that this only affects current master, not any released version.

Ouch, I was too fast then.
if you agree, we can leave it Open and close it once your work with bug 83877 is finished
Comment 5 Samuel Mehrbrodt (CIB) 2018-01-26 11:09:37 UTC
(In reply to Xisco Faulí from comment #4)
> Ouch, I was too fast then.
> if you agree, we can leave it Open and close it once your work with bug
> 83877 is finished

Fine with me
Comment 6 Timur 2018-03-23 09:28:49 UTC
Looks like fixed now. 
I guess import is this:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=39fd78b79efd00e27ea068c03edf83b9dc6b9b57

tdf#83877 ODF: Load signature lines
Actually a dupe.

LO reads signature line from DOCX, RT DOCX, RT ODT. 
MSO 2013 reads RT DOCX and doesn't read signature line from ODT.
Comment 7 Xisco Faulí 2018-03-28 14:19:52 UTC
Verified in

Version: 6.1.0.0.alpha0+
Build ID: 8329f4541e27402d19729ae1588af8bfe61f7b49
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Thank you Samuel!!