Bug 115242 - FILEOPEN: RTF: Incorrect left indent
Summary: FILEOPEN: RTF: Incorrect left indent
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.1.0 target:6.0.2
Keywords: bibisected, bisected, filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2018-01-26 14:48 UTC by Xisco Faulí
Modified: 2018-02-14 11:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (169.85 KB, application/rtf)
2018-01-26 14:48 UTC, Xisco Faulí
Details
comparison MSO 2010 and LibreOffice 6.1 (196.70 KB, image/png)
2018-01-26 14:49 UTC, Xisco Faulí
Details
sample 2 (182.93 KB, application/msword)
2018-01-29 11:43 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-01-26 14:48:30 UTC
Created attachment 139375 [details]
sample

Steps to reproduce:
1. Open attached document
2. Go to page 2 and compare the indent before the bullets and numbering. See attached image

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 5cb225b0b3dbb55fd44899b1fb16bdcfeb866849
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-01-26 14:49:37 UTC
Created attachment 139376 [details]
comparison MSO 2010 and LibreOffice 6.1
Comment 2 Xisco Faulí 2018-01-26 14:59:01 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-01-26 13:21:28 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-01-26 13:21:54 +0100
commit	3915bf2dc877d5f1140798e24933db0f21386a4a (patch)
tree	bcc1034371fa11953556b3400f520ee593760727
parent	09e46424c510924bae09c6e0147095e2958fa009 (diff)
tdf#95376 DOCX import: fix incorrectly indented tab stops

Bisected with: bibisect-linux-64-5.2

Adding Cc: to Miklos Vajna

The situation has improved in c9dee880d88305312094b311abdae155e452bf14 as the numbering indent after 3 is correct now
Comment 3 Xisco Faulí 2018-01-29 11:43:58 UTC
Created attachment 139428 [details]
sample 2

another file affected by the same commits
Comment 4 Miklos Vajna 2018-02-01 16:40:53 UTC
I can't see this happening on master, but I do if I revert my recent fix for bug 115155, so I guess this is a duplicate.

*** This bug has been marked as a duplicate of bug 115155 ***
Comment 5 Xisco Faulí 2018-02-01 17:12:44 UTC
Hi Miklos,
Indeed, the first document looks correct in

Version: 6.1.0.0.alpha0+
Build ID: 9baa3fcf1f414c74d2ea1b55b2cb358527fe7364
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (C); Calc: group

and the left indent on the second document as well. However, the spacing between the numbers and the text is incorrect compared to previous to 3915bf2dc877d5f1140798e24933db0f21386a4a.
Should it create a new issue instead ?
Comment 6 Miklos Vajna 2018-02-02 10:21:45 UTC
Yes, I see, the second document has A.2. "prepare" and "a." (in the next line) at the same vertical line in Word, but not in LO. Let's use this bug for this purpose. :-)
Comment 7 Commit Notification 2018-02-06 09:54:49 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03cee02464f230a2efa67d131c137f32fe540052

tdf#115242 RTF import: order numPr before other paragraph properties

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-02-09 15:02:11 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ecff2a84e2766dd93bd028e065d9ea3d833b369b&h=libreoffice-6-0

tdf#115242 RTF import: order numPr before other paragraph properties

It will be available in 6.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2018-02-14 11:25:52 UTC
The situation is much better now with sample 2 file.
However, it's still not perfect compared to before 3915bf2dc877d5f1140798e24933db0f21386a4a.
I'll create a follow-up bug...