Bug 115266 - Style modification dialog : line width shown in default unit (FORMATTING, UI, enhancement)
Summary: Style modification dialog : line width shown in default unit (FORMATTING, UI,...
Status: RESOLVED DUPLICATE of bug 72662
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-28 00:11 UTC by divers
Modified: 2019-03-04 20:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
After changing default unit to Points.... Style modification dialog, Line tab, shows points for the line width. (28.16 KB, image/png)
2018-01-28 00:12 UTC, divers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description divers 2018-01-28 00:11:44 UTC
Description:
I am using Draw.
We are all used to setting the lines width by "points" in office applications.
In Draw, in the properties of a line, the unit for line width is shown in points, independently of my default unit setting in Options (set to Inch).

However, when I want to change the default line width for a style in the style properties dialog, the Line tab shows the width unit according to the default unit from options. In my case that's in Inches, and that does not tell me a lot as far as a line width.



Steps to Reproduce:
Open the dialog to modify a specific Style properties.

Actual Results:  
Line width is specified in the default units (from the Options dialog).

Expected Results:
Should show the same units as the the Line properties dialog, or at least give the choice to specify the actual unit when I enter a value.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 divers 2018-01-28 00:12:18 UTC
Created attachment 139399 [details]
After changing default unit to Points.... Style modification dialog, Line tab, shows points for the line width.
Comment 2 divers 2018-01-28 00:13:47 UTC
Comment on attachment 139399 [details]
After changing default unit to Points.... Style modification dialog, Line tab, shows points for the line width.

After changing default unit to Points.... Style modification dialog, Line tab, shows points for the line width.
Comment 3 divers 2018-01-28 00:26:39 UTC
The work-around to the unit display issue is:
1- go into Options
2- change the default unit to Points
3- go to Style modification dialog, Line tab
4- enter new width in Points
5- go back to Options, revert units to Inch

Please note:
If the default units are set to Inch, and I enter XX pt in the Width box of the Line properties in the Style dialog, the dialog will accept it.
HOWEVER, the actual line width on screen will be different than other lines which were manually set to the same XX pt width in the individual Lines properties.

To reproduce the Point vs. Inch accuracy bug :
1- switch the units to Inch in Options
2- go to Style modification dialog, Line tab
3- enter "1 pt" in the Width box
4- switch the units to Points in Options
5- go back to Style modification dialog, Line tab
6- The actual value shown in the Width box will not be 1 pt, but 0.7 pt
Comment 4 Buovjaga 2018-05-28 10:47:11 UTC
Thanks, I found a duplicate by looking at this meta report: https://bugs.documentfoundation.org/showdependencytree.cgi?id=103428&hide_resolved=1

Regarding your additional note in comment 3, you could search if a report already exists and if not, perhaps open a new report
https://bugs.documentfoundation.org/query.cgi?query_format=advanced

*** This bug has been marked as a duplicate of bug 105176 ***
Comment 5 Buovjaga 2019-03-04 17:37:41 UTC

*** This bug has been marked as a duplicate of bug 72662 ***
Comment 6 Luke 2019-03-04 20:10:38 UTC Comment hidden (obsolete)
Comment 7 Luke 2019-03-04 20:11:40 UTC
There are several issues here. 

1) Two decimal places is not enough precision to represent inches for line width. See Bug 44267

2) The natural unit for line width is point. See Bug 72662

3) For the conversion issue: 1 point = 0.013889 inches
See Bug 122562, comment 4 for an explanation