Download it now!
Bug 115271 - LibreOffice Impress printing to paper & *.PDF(cups & to file) = fail. Impress will only allow printing on US Letter (8.5" X 11.0").
Summary: LibreOffice Impress printing to paper & *.PDF(cups & to file) = fail. Impress...
Status: RESOLVED DUPLICATE of bug 65205
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-28 07:27 UTC by UbunLibOffImp
Modified: 2018-02-19 10:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description UbunLibOffImp 2018-01-28 07:27:26 UTC
Description:
Environment = Ubuntu 16.04 & Firefox 58 & LibreOffice Impress Version: 5.3.7.2

No combination of printer presets, printer options or printer configurations at the OS level will allow a user to select paper size.
Impress is not aware of the size of the slide.
Impress does not acknowledge printer configurations.
In summary, the print dialog box is totally broken.
None of the options listed below function in any sort of way:

Print > Options
fail = [checkbox] Use only paper tray from printer preferences
fail = [checkbox] Use only paper size from printer preferences

Print > General > Properties... > Paper
fail = [dropdown] Paper size == greyed out
fail = [dropdown] Orientation == greyed out

Print > General > Properties... > Device
fail = dialogue box does not read in any of the printer settings

Steps to Reproduce:
1.Create a presentation that uses a 19"X13" slide
2.Try to print this slide (shrink to fit to 11"x17" / Tabloid / ANSI B)


Actual Results:  
The only possible (paper & *.pdf) output will be a US letter sized document. 

Expected Results:
This used to work in 5.1.X.X.
It used to be possible to print to something other than a US letter.


Reproducible: Always


User Profile Reset: No



Additional Info:
Please fix the "Black and White" printing output.
It should be easy for the user to print without the background image and have all entities converted to black or greyscale on a white background in order to make paper printing possible. This is a important requirement for a corporate environment.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Buovjaga 2018-02-16 19:38:08 UTC
Please try with 6.0. I am able to print to any size when I use the "use only paper size" option.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 26783527823883ccd5bbf3b9e014a0a3c1e3a022
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 16th 2018

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Timur 2018-02-19 10:14:15 UTC
Looks like a dupe of Bug 65205.
If you disagree, please explain.
As for B&W, there's Bug 106675 that you can follow.

*** This bug has been marked as a duplicate of bug 65205 ***
Comment 3 Timur 2018-02-19 10:17:01 UTC
Please also comment on Bug 95694.
When reporting a bug, you should always test with master: https://dev-builds.libreoffice.org/daily/master/. It doesn't mess with your working version.